Beryl AX AP Mode no GUI access

Hello, I’ve done some reading up on how this is supposed to work, but I haven’t been able to find a solution to my problem.

My network setup is as follows: Flint as main router, ethernet cable to a switch elsewhere in the house, Beryl AX connected via ethernet to Flint (Flint LAN to Beryl WAN) and then I put the Beryl into Access Point mode. My laptop plugged into the LAN port on the Beryl gets an IP address from the Flint router, devices connected to the Beryl wifi can access the internet and get IP address from the Flint router, it seems to work great, except I cannot access the GUI of the Beryl AX.

I’ve tried:

  1. Looking at the client list on the Flint and trying to connect to the Beryl listing there. No luck. Pings don’t work either
  2. manually setting the IP address for my laptop to the IP address in the range of the Beryl when it was in router mode. No luck. Pings didn’t work
  3. manually setting the IP address for my laptop to the 192.168.8.x default range of the Beryl it had when it came new. No luck. Pings also didn’t work.

What kinda worked:

  1. I was able to get the cloud interface on my cellphone’s app to work. I could see the router, could control the wifi settings, and see that it said it had the same IP address that the Flint router said that it had. But I still couldn’t ping that address or reach the GUI on my laptop.

However, once I restart the Beryl it stops being available to the cellphone app and also changes it’s client listing on the Flint to a slightly different MAC address. (Router mode ends in A4, AP mode ends in A5)

more info: restarting the router changed nothing about being able to access the GUI, and I can reset it back to router mode using the reset button with no issues.

I’m using firmware version 4.2.2 release2, the most recent stable version. Hardware acceleration is on if that matters, but I don’t think it does.

Update: I figured I’d try the beta firmware and decided to test the beta firmware and I also didn’t keep settings when upgrading. AP mode worked as intended after the upgrade, and then again when I downgraded back to stable 4.2.2

Now I just need to figure out what in my settings before made it behave poorly.

1 Like