Beryl AX destroying my sanity

Long story short:

  • I am using Beryl AX as a way to connect my telescope to my home network
  • I am trying to use it in the extender mode
  • It worked ONCE for one night, then never again, which is driving me insane as I have not changed anything…
  • Help desperately needed!

Overall setup:


  • If I connect astro management app on the iPad directly to the AsiAir (telescope controller unit) through AsiAir own short-range wifi, everything works!
  • If I connect to the internal BerylAX wifi (GL MT-3000) everything works!
  • If I try connecting using home network, it doesn’t - it worked once, then never again!

What I tried:

  • Putting the Beryl AX into Repeater mode and into Extender mode (not sure what’s the difference)
  • Putting the AsiAir into a DMZ
  • Forwarding all the ports relevant for the ASIAIR via port forwarding rule to ASIAIR reserved IP

What I get at best: I can see AsiAir in the AsiAir iPad app, but can’t connect to it.

Please help/advise!

Could you please include IPs in your diagram? That’s necessary to understand the issue.

This time uploading the right picture - with IP info added!

For the record, with port forwarding I am forwarding the following:
4350, 4360, 4400, 4410, 4500, 4700, 4710, 4720, 4800, 4810, 9624

In that case, you will need to investigate further what ports are required (and if they are UDP or TCP - because UDP isn’t routable).

The base setup seems OK.

It has been pointed out to me that the current setup uses two different subnets. How do I configure Beryl AX to use the 192.168.1. subnet without it being the main router and conflicting with the main router?

Which one is the main router?

Unifi gateway, connected to the unifi switch.

Dang, should have included that in the diagram, apologies!