Beryl AX firmware 4.4.6 connection issues and feedback

Hi, I have been using the Beryl AX for a while and wanted to share my feedback about a few bugs I have found, I am currently on the latest stable version 4.4.6

First, when I am using Network Storage (Samba server) the Wi-Fi starts working strange, when I am on my room the internet just stops working even though I have a good signal on my phone, 2 bars. The internet only works when I am next to the router, like 2-3 meters away. As soon as I disable the Samba Server it starts working normally, I have internet all around my house again. This is strange because the router is next to my room, I know signal or interference isn’t the problem, I have tried changing a lot of things. It doesn’t disconnect from the Wi-Fi, it is just the internet that stops working. Also the SMB Server isn’t stable, stops working quite often when transferring files, I have read this will improve on v4.6. The problem seems to happen only on the 2.4GHz band.

I am using AdGuard Home, OpenVPN Client based on VLAN policy and those work great. However the router used to lose the WAN connection sometimes, I had to restart it every time, I set the router to automatically restart once a week and it’s been working fine, not sure if it was solved on v4.4 though.

Is the Beryl AX is powerful enough to handle AdGuard, OpenVPN Client and Network Storage at the same time?

Also, when I have 2 signal bars on my Android phone (WiFi 6) the upload speed is super slow, only 2mbps whereas the download is normal, once I get closer it gives me my line speed, that is strange as well.

And the last thing, the range, I can only set the TX power to 20dbm (100mW) I would like to set it at 24dbm at least, I have better range on my old Opal SFT1200, I can set it to 1000mW. I have read this will improve on version 4.6
Thank you for reading

This problem is due to USB3.0 and 2.4G interference.

Is there a way to solve this or mitigate it? That means we can’t use network storage and 2.4G at the same time? I tried both with ax external HDD and extension cable and a USB Stick.

You can use 5G wifi when using network storage. What is the reason you have to use 2.4G?

Well, range. 5GHz has a poor range in comparison, I think I will use a USB 2.0 extension or Stick

If you use an external drive with USB 3, try to use a better shielded cabel with ferrite cores. You can also try an USB3-stick but some of them have problems with radiated emissions too.


Wrap it in tin/aluminium foil. Tape the overlapping seams. Seriously. Then get dem shielded cables & ferrite cores.


Thank you, I think I will try this cable, seems the right one

You can buy lots (eg: 5,10, 20+ pieces) of just ferrite ‘chokes’ for your USB cables for reasonable prices. Measure the outer diameter of the cable(s) to get a proper fit.

I got that cable from Amazon let’s pray it works, it comes with a ferrite core, gold plates, not sure if that will be enough, if it doesn’t work I will wrap it in aluminum foil. Do you have a recommendation for a good shielded USB cable?

1 Like

It looks like a solid choice.

Heh; the gold plating around the connection shroud doesn’t mean much unless you’re around the sea a lot. It’s the gold for the pins that’s the important bit. :wink:

For USB cables I look to Anker or UGREEN. Anker is my usual preference as most… note I say most… of their cables are back by a lifetime warranty. I hate buying twice. ‘Buy one, cry once’ & all that.

1 Like

Even with that cable I didn’t work🥲 without the cable (using a USB stick) I wasn’t even able to connect to my 2.4GHz WiFi on my backyard, now I can connect but there’s no connection unless I get closer to the router, even having full signal on my backyard or room I don’t have internet access while the USB is plugged in, at least it improved with the shielded USB cable with ferrite core, this interference is so strong, please add a USB 2.0 mode only on the glinet UI. I can’t use network storage sadly and that is something I really need

I finally solved it using an old USB 2.0 cable I had, connected to the USB cable I posted on here. Now it’s working great and I have no interference at all


It’d be interesting to see if a USB3.0 cable covered in ferrite chokes would solve it.


1 Like

Honestly I think I wouldn’t help that much, the USB cable I posted here has a thick aluminum shield, even on the port itself, I wrapped it 2 times too haha, and still had a lot of interference, after trying with so many cables I had the solution was to use USB 2.0 and the cable with ferrite core together

Humm… I’m going to suspect RFI is hitting the USB->SATA bridge built into the drive chassis then. I really would wrap it the drive tight in a couple of fully encompassing layers of tin foil.

For science!

Yeah, that RFI is so strong, it’s crazy. I ended up using a USB stick though because the SMB speed is about 15MB/s. I also have a USB 2.0 hard drive case which worked well but sometimes it would lose the drive’s connection.
Fun thing, my aluminum USB stick was getting a bit hot and I added 4 mini heat sinks with thermal glue. Working like a champion haha

Clever. Those blocks were probably helping reflect RFI, no doubt. SanDisk has/had a bad reputation for models of their really tiny USB3.0 drives burning up under load.

This is what I did, I use those ones for arduino projects etc, it even looks good to me😂 I have a SanDisk, this one doesn’t get as hot as my other Samsung stick but you’re right

1 Like

Heh; that’s still too much surface area. These are the lil’bastards w/ the bad rep:


1 Like