Beryl AX freezes under high wifi load


I’ve got Beryl AX and recently moved to location with a high-speed ISP connection (500/500). The router freezes few seconds after I start downloading files at full speed on my laptop, or the problem can be simulated via Iperf3 between devices. Only power reset helps to unfreeze the router.
I tried to simulate the problem connecting one of my device through ethernet and making Iperf3 tests, but another device is still connected via Wi-Fi, so the problem persists when high wi-fi load occurs.

The settings are:

  1. Firmware version is 4.4.6 (the problem persisted on the previous version as well);
  2. Ethernet WAN;
  3. Only 5ghz Wi-Fi enabled (no 2.4, no guest networks) at Medium TX power, ac/ax mode and WPA3 security;
  4. LED is disable;
  5. All clients are wireless AX-capable devices (two laptops with 2.4Gb/s negotiated, one with 1.2Gb/s and AppleTV with 1.2Gb/s as well);
  6. WG client is ON but only for AppleTV, and bandwidth is never more than 20bmit/s. has never been actively in use when freezes occur;
  7. no custom plugins;
  8. Hardware Acceleration is ON (tried to turn OFF, but got the same freezes);
  9. Genuine power supply.
  10. Temperatures are below 70C all the time, the fan is not trying to start yet;

Appreciate any help.

Also noticed that the router makes a high-pitched noise when “frozen”.

I got this noise too in my beryl, but I need to put my year very close to the router to hear. It calls coil whining and it happens when there’s too much load.

Now did you try with another power source? I suggest you to try and see if it freezes too.

Just tested with 20W Apple charger and cable - the same :thinking: Both power supplies are slightly warm, close to ambient temperature.

Try to run htop while downloading. Might be that the CPUs just hit the limit.

Still shouldn’t freeze.

Honestly so far in my testing the GL inet devices are pretty buggy and not very stable. My Beryl has had heaps of issues with Repeater mode, although disabling 5ghz helps, but shouldn’t be required.

Might be worth trying 4.5 Beta firmware?


Should not freeze. Can you test 4.5?

iperf3 is what we used frequently to test wifi as well.


Depends. It will be some try 'n error as well.

Honestly so far in my testing the GL inet devices are pretty buggy and not very stable.

In my opinion, the biggest problem with the GL.iNet devices is due to 2 triggers:

  1. software quality. This needs to be addressed again. Some things are not sufficiently tested or are “unstable”.

  2. false expectations: Many users buy a cheap router and expect it to solve all their problems. Then they sometimes start with completely unrealistic ideas, even though they know nothing about IT networks. VPN things in particular are like this: You can’t just have “VPN” on a router without a basic understanding.

When I consider that a reputable router here in Germany costs 250 euros and a similarly powerful GL.iNet router only 100 euros … then you realize that you can’t expect the jack of all trades.

I’m very happy with the Flint, it does what it’s supposed to. My Opal is a bit weak on the chest, but works quite well on the whole.

I’m really looking forward to the Flint2, but I also like tinkering - which is somehow a prerequisite for OpenWRT-based routers.

Edit: And I really enjoy the community support here. Thanks for that, GL-Team!

CPU Average Load is about 0 to 2 when downloading, which is as expected because I’m not using any VPN or complicated firewall rules with it, just Wireless LAN.

I’ll test and get back with results. Thank you.

Nope, upgrading to 4.5 didn’t help… The router couldn’t take it more than 2 minutes this time, but sometimes it takes only seconds to freeze. Due to temperature? It’s about 60C after boot up, 63-66C in idle and rising to 70C while downloading till the freezing. Can I redefine the fan speed for testing purposes? Maybe some power components get overheated… :thinking:

Use a better quality usb power supply and cable. Any 5 volt 2 amp output should be fine and some generic adapters and cables can work better with other devices than high branded stuff. Importantly, the power supply and cable should not show any signs of heat unless used for a long time and should be taken as a sign of stress on the equipment because of the down conversion from a higher voltage. This is why I bought sockets that include usb ports because the step down conversion is done where the power can be split so little to no heat is generated on the usb. Plug adapters will always get hot.

For cables I use either stock or big thick xiaomi 6amp capable cables.

If it’s not a power issue and you aren’t bothered about setting it back up then revert to stock and see if it continues to lock up. That’d be my first.

Maybe it is the case. You can adjust the fan speed in system dashboard

Op said limit is set for 70c but 70c isn’t reached.

Update, my bad… Op posted while typing my essay… Bin this idiot…

Would it be the fan itself attempting to kick in and… Fault? Can the fan turn?

The Temperature Threshold is set to a minimum of 70C, but I can’t reach it. I’ll try to pack the router inside a t-shirt and check if the fan is able to spin. I was thinking that some component else might suffer from overheating, so I would try to make a stress test with a full fan speed if is possible to set it manually.

I presume that 20W Apple charger kit has more than enough quality and capable to power up the router not worse than the genuine one. Resetting is the thing I was considering, will try if nothings helps.

Quick update:

I’ve set the fan offset to a maximum with the command below, which gave me 5500+ RPM of the fan speed and 59-60C of the CPU temp during stress-test… 6 mins and everything is good so far.

echo 255 > /sys/class/thermal/cooling_device0/cur_state

upd: the CPU temp is 55C and keeps dropping…

I suppose we should all be grateful that apple doesn’t charge extra for the fact it’s compatible with other devices… I probably speak too soon though.

Just because it has an approvement by a company doesn’t mean it has an approvement in the field. You’re entitled to a replacement if it’s faulty. That’s what you pay extra for. Otherwise under the plastic you’ll find the finger prints of the same child worker as any other brand. Not taking a stab or anything but we don’t get what we pay for these days. Quantity over quality is far too common now.

I’m not trying to say that apple devices are better than any others. Ugreen, Baseus, Anker, etc., can offer much more valuable things for the price, it’s just what I had to test the powering and not the worse thing on the whole market.

I guess the problem is resolved after changing the behavior of the CPU fan. 47 vs 70 threshold in config. The fan is totally silent until ~3700 RPM.

config globals ‘globals’
option enabled ‘1’
option sysfs ‘/sys/devices/virtual/thermal/thermal_zone0/temp’
option warn_temperature ‘76’
option div ‘1000’
option temperature ‘47’