Beryl AX internet not working

Hi, I’m having some issues with my Beryl AX, the internet stops working having a strong signal, literally being like 6 meters away from the router, the signal shows 3 bars on my Samsung device and 2 bars on my iPhone. Curiously the internet works fine when I’m next to the router. But I need to get extremely close. And the walls of my house aren’t the problem because the router used to work fine for over a month and now this started happening suddenly. I even tried different antenna angles. I think it’s like a bug in the router. I need help please, thanks.

And sometimes I can’t even connect to the 2.4 ghz band (6-7 meters away from the router). It used to work fine before all around my house:(

Try choosing a different channel in your wireless settings. Could be heavy signal interference or something causing issues.

It is set to “auto”. Should I try a manual channel?

Yeah you can pick 1, 6 or 11 for the 2.4 GHz spectrum, and preferably a DFS channel for the 5 GHz spectrum.

You can head over to the LuCi interface (there’s a link under “advanced settings” in the web ui) and perform a channel scan to see which channels have the least interference. This is very helpful if you live in a crowded area.

I believe it’s the firmware 4.2.2. Go back to 4.2.1 and your signal will be back to normal

1 Like

Nope, not working, I changed to channel 6, downgraded to 4.2.1, and even to 4.2.0 and nothing works, still no internet having a strong signal on my room. That bug is so weird, I hope there is a solution. I upgraded to 4.2.2 again since nothing worked

Very strange you’re still having this issue. It could be something hardware related, or a bad firmware install from the factory. I’d try getting GL.iNet to exchange it for you. I have two of these same model and they work great.

I had this problem as well. I downgraded to release 2 of 4.2.1. Once you successfully downgrade, reset the MT3000 by pushing the button for 10 seconds, and everything goes back to normal—at least for me. I tried several release of the firmware versions above 4.2.2, including the stable version, but experienced the same problem. internet becomes very slow.

I tried to disconnect my external USB SSD and seems like it is working fine now, maybe that was the problem, but now I am not able to use my SSD. I was usig an USB extension for the SSD so I don’t think it is some interference

I also discovered that sometimes the internet suddenly drops, it shows a red icon on the glinet app, and then if i restart the router it works normally, it happens like every 4 or 5 days, but I will wait to see it my USB SSD was the problem.