Beryl AX is sooo finicky (after 1 month of daily use)

Beryl AX is sooo finicky

Want to preface this with that I love the idea of having a mini router with me. Everything from multi WAN (tethering + wifi repeater), to having VPN baked in is really cool and exactly what I want. A bit of background: I’m working in IT, I (think) I know my network stuff and have a good bit of experience administrating servers.

I got my Beryl AX last month and packed it for a longer trip abroad. It’s been now a month of almost daily usage with an unlimited data SIM and so far it feels just so dang finicky. Half the time I spend the first 10-15 minutes just setting it up and hoping that my internet works now. I’m at the point where I’m wondering if I should just not pack it and tether directly from my phone instead, because that seems to be far more reliable. Right now I’m still using the Beryl AX, because I want it to work, but I am close to switching to my phone wifi instead.

My setup:

  • Samsung phone with unlimited data SIM
  • Connected to Beryl AX through USB cable, tethering through USB enabled on the device. Occasionally tethered through WiFI when USB is having issues
  • NextDNS setup through manual DNS
  • Repeater set to cafe wifi as fallback
  • Other stuff that’s enabled: Tailscale (not exit node), IPv6, DDNS, Hardware acceleration
  • Network mode: router

The phone has internet, devices that use the phone tethered wifi directly have internet, but devices that use the beryl have constantly sites not loading. This is also when changing the DNS to automatic, and just using NextDNS on the end devices instead (my point is, it’s not a DNS issue).

When I try to use repeater only, I often get issues that it can’t join the WiFi, even when forcing 5g or 2.4g.

Are there problems with the hardware when tethering from an android phone through USB? I tried switching between WiFI and USB, and it feels like WiFi repeater is a lot more reliable/stable, which is unfortunate because I don’t want to have 2 devices next to each other that both create a wifi network.

Am I doing anything wrong with the way I use it? Any tweaks I can do to make it more reliable?

Anything I can try here?

Whats the firmware?
Are you using the original power adapter?
Have you mangled the TTL on the phone so that Cellular provider doesn’t know it is tethered?(even if you have a unlimited sim they might be throttling it)
Hardware acceleration might be causing a issue.
Packet steering in LuCI has speed up WiFi for people.
It you would help if you posted a Log.

1 Like

Thanks for the reply!

I’m on 4.2.1, not using the original power supply but a few usb-c cables. Mostly an Anker, Apple or Samsung cable, whatever is in my bag. I power the device either through an anker power bank with USB-PD or a power supply that supports USB-PD as well up to 65W, and very occasionally through my Macbook if I don’t have anything else with me.

The Cellular provider has no issues with tethering and it’s working fine through WiFi when not using the Beryl in the middle. Right now the Beryl is working fine as well, but it took a while to get there, when I wrote that post it didn’t :smiley: I did turn off the repeater completely now though, and only use USB tethering. So another theory I wanted to debug later is if problems increase when using both at the same time

I haven’t heard of TTL mangling on tethered connections yet, let me read up on that! Does this need to be on the device itself, or can I do this on the Beryl as well to mask it?

Let me try the suggestions you made, namely: Hardware acceleration, and packet steering.
I’m wondering about hardware acceleration - why could this be causing issues? I just assumed that having it on would always result in better performance because more tasks will be unloaded from the CPU

Which log can I share for debugging what might be happening?

Switch to the original power adapter if available.

1 Like

Also try 4.2.2 beta and you may need to change a firewall setting to enable both the Repeater and Usb tethering (MT3000 USB Tethering broken when Repeater mode is ON - #6 by alans)


It’s interesting to me how many different usage patterns there are. In particular, the things you like about it don’t figure at all in my scenarios. And you have layers of complexity I’ve never attempted. So just throwing out a few suggestions:

  1. Power can cause a lot of issues. USB-PD is actually a problem to be aware of. Every time you plug a device into a PD charger, the power is renegotiated, which means it is off and the router reboots. USB-C is a massive convenience, and the GaN bricks are also convenient, but you have to be aware of the reboot.
  2. After a reboot, or after changing the WAN connection, it can take some time for things to settle in place.
  3. DNS and IPv6 are problem areas for all routers, I think.

For me, the primary advantages are (1) only having to make one WAN connection for the router and then all my other devices are connected; (2) adblocking; and (3) acting as a VPN client to the mother ship.


Yeah, lots of different usecases. For me the small form factor make it perfect for traveling and having a stable connection with me. Esp the fallback allows me to turn less stable wifis into something more stable. For example when I needed a lot of bandwidth, I connected 2 tethered phones (one through USB, one through Ethernet) and set the router to load balance.

I can’t pack the official power adapter because that’s taking too much space with all the different adapters for each country, so just USB-C with a solid PD brick felt like it would give me the most versatility. I tried this of course at home a couple times to make sure the things I pack can actually power it reliably

I don’t use the adblocking stuff and leave that to NextDNS (or just ublock), but I use NordVPN a lot.

I tried the beta and checked the settings from that post, but it looks like that firewall rule is already disabled out of the box? At least the little enabled checkbox isn’t checked. Was it not for you, or did you delete the rule entirely?
But the post sounds like it may be what I’m dealing with as well, tethered connection + WiFi seems less stable than just tethered connection alone.

I’ve since disabled IPv6 (most networks don’t support a proper IPv6 stack anyway so it’s causing more issues than benefits), enabled package steering and disabled hardware acceleration. Will report back if it changes anything.

There’s still a lot of messing with settings, esp. around DNS, Tailscale, VPN and so on (4.2.1 breaking VPN DNS for example). In my dream world I want to plug it in, wait until it’s powered, and then have my stuff working, independent if I’m on a cafe wifi, have my phone connected through USB tethering, or use something else, and not open the interface all the time to tweak things before my internet connection is working.

For example, captive portals not working properly when using any DNS setting. Or NextDNS ID getting wiped when switching DNS (separate post about that on here already), same for custom DNS forwarding options with tailscale.

Maybe just leave everything to auto, but there should be a way to have it set up properly once and then leave it

I was on 4.2.2 release 1 and they did incorporte the fix into release 2: