Beryl AX issues with Channel 1

hey there,

I’ve done a good bit of troubleshooting as to why an IoT device (door lock bridge) that I have keeps disconnecting from my new Beryl AX 2.4Ghz wireless network: channel 1 is having issues.

However I do not believe this is due to interference. I have my Beryl setup in AP mode, bridging to the ISP supplied router which is broadcasting the same SSID values on both 2.4 and 5Hz. So this is a roaming network. All other values are equal b/g/n/ax and WPA-PSK AES, channel width 20Mhz. No band steering on ISP router. I have the primary AP on Channel 6, Beryl on 1 (and for 5Ghz 149 , 36 respectively. The door lock can only see 2.4Ghz, so this issue doesn’t involve 5Ghz at all.)

While keeping a ping running to the door locks IP, Channel 1 on Beryl is really flaky. If I switch the ISP router to Channel 1, and Beryl to 6: the connectivity is very stable. Note Beryl is literally 1 metre away from the door lock, the ISP router is about 15 metres away. So 2.4ghz should be a lot stronger from Beryl. Each time I tested, I was disabling 2.4Ghz on either Beryl or ISP router - so I knew the door lock bridge wasn’t flapping between APs.

I tried all combinations of b/g/n/ax modes to see if the door lock is better in legacy only mode. No difference. Also bear in mind I don’t see any issues with other clients connecting to Beryl on Channel 1. But as the door lock is very stable on Channel 1 of the ISP router - I’m of the opinion there is an issue with my Beryl, or the immature drivers? Leaving Beryl on Channel 6 or 11 is very stable.

I’m avoiding using Channel 1 on Beryl for the time being - just thought to right up on the forums incase staff/ others interested.


This issue came back, and regardless of channel used.

I tried with and without hardware acceleration too. Maybe 4.2.2 latest driver has an issue?

Hi,Will it work with other firmware?such as 4.1.3,4.2.0,4.2.2 Firmware updated the driver of WIFI. We are considering replacing the stable WIFI driver in the next firmware.

I haven’t yet tried downgrading… I only had my Beryl AX for 6 weeks so only ever used 4.2.2 release.

I hear in other thread linked above 4.2.1 might help with 2.4ghz client stability.