Beryl AX (MT 3000) won't connect to as repeater in Malaga Spain

Just arrived in Spain excited to give the product a go. Now 4 hours later… and reading countless reviews on the topic. Has anyone come closer to arriving at a real solution, vs workarounds like tethering a phone connection?

I saw a link about a wifi driver also, but have no idea if there is a special place on the router to load that new driver/firmware.

This has proven quite frustrating and hopefully the community has found a real answer.
Many thanks in advance.

Screenshot 2024-02-22 213548

1 Like

Do you have AdGuard Home enabled? Have you changed the DNS settings on the router? My MT3000 works fine as a repeater on both 2.4 and 5GHz, also try the randomize mac option

Hey Steve

  • No Adguard
  • Haven’t changed DNS settings (not even getting an IP address to begin with, so not sure how that would help at that stage.
  • Tried both factory and random. No difference as it just stays stuck trying to get an address as shown in 2nd screen shot.

So here’s an update for you (still a workaround but definitely insightful)

  1. I connected to the Hotel Wifi via laptop.
  2. Enabled Hotspot on my latop
  3. Connected the Beryl AX to my laptop wifi hotspot (still in repeater mode)
  4. Now the Beryl AX can repeat my laptop’s wifi (which is repeating the hotel’s wifi)
  5. I am even now able to apply my PIA Open VPN configuration on the Beryl AX.

To me this definitely indicates somehow that Beryl’s firmware or connectivity seems to be the root cause of these issues. I don’t know what my older Surface Laptop 3 is doing so fundamentally better and more efficiently than a Beryl device that is specifically created to address this issue.

I have tried “cloning” the Laptop’s MAC, but that clearly also does NOT resolve the issue.
I know this is largely the community out there, but I’m really hopeful that someone from GL iNET can clearly look through all the related logs and come up with an SOLUTION, that doesn’t require the average use they pitch their product to, to have a profession or PHD in network engineering.

Try going into the LuCI interface, go to Network-> MTk WiFi and check if the country is Spain. If not, change it to Spain.

Theres a possibility the hotel router is using an encryption the gli doesn’t understand. Check the encryption protocol from the laptop and make sure its wpa/wep. If its EAS or something then it won’t connect at all.

Things to try.

Static IP and mac clone of laptop. Mac and ip are tied.

Ask hotel staff if its possible to connect travel routers to their network, often staff will already know.

Settle for the config you have until you have proper time to figure it out.

Yep. I’d already done that. No difference. Thanks!

Don’t think static IP will work if it won’t resolve any IP at all (nor gateway/DNS) per the first screen shot. The captive portal network security is Open. But here I’ve uploaded the security settings. The only thing I’m less familiar with is the impact DFS will have on things and if there are any special adjustments to be made as a result. Please see original screen shots uploaded. Hopefully this helps someone diagnose. Let me know if you need anything else.

Copy the network details of the laptop into the router as static address and try to connect. It probably won’t work but if you don’t try you’ll never know.