Beryl AX MT3000 No Internet using repeater

I agree!! A lot, if not most, places I visit where I want to use the repeater only have 2.4g wifi….

1 Like

My experience on the way shows 2.4G and 5G are all good to use.

I don’t have many problems with MT3000 actually.

But these problems are mostly related to country code, bands etc. so I have to check more details if there are issues.

One hint is that, you set the 2.4G and 5G SSID/Key to the same so that your phone is not disconnected during connect.

For example, your phone/laptop is connected to the 2.4G wifi and you use 2.4G wifi to connect as repeater, you may have disconnect.

But when setting the 2.4G and 5G SSID/Key to the same, your phone/laptop can always find one signal to connect.

Fair enough; can you elaborate on your suspected Country Code band reasoning please?

Again (and sorry to keep on about this) if you could update your F/W and GLiNET App to allow these Country Codes to be changed (quickly and easily), then you can simply tell folks who you suspect might be using the wrong Country Code (where certain frequency bands are not permitted), to just change to the permitted Country Code.

This way they can test, very quickly, if the source of the inconsistent Wifi is indeed related to the (incorrect) Country Code; or is actually the guy in the next hotel room firing up his microwave oven.


1 Like

I have the both the keys for the 2.4g & 5g set to the same thing.

agree with you and trying to find a solution.

There are a lot of things related to repeater. When there is a problems need a lot of details to investigate.

  1. 2.4G channel 12, 13, 14, only some coutries support these. Generally the problems is cannot find the ssid.
  2. 5G DFS channel, DFS has more troubles, has to detect radio signal which could be slow
  3. 5G Band 4 channels. Europe regulation said these channle is usable with 25mWatt but generally these channels are not usable on routers
  4. Channel bandwidth. H20, H40, VHT80, VTH160. Use narrow band is more stable
  5. wifi signal strength. When wifi signal is weak, generally AP will kick you out
  6. Multiple BSSID auto switch
  7. portal does not pop up: forums has some discussion. Most of the issues are related to DNS and VPN.
  8. WPA3 etc. e.g a recently fixed bug to connect to IOS hotspot
  9. Weird things e.g. Slate AX1800 not broadcasting 5Ghz WiFi - #10 by alzhao which is bug of IOS
1 Like

Thanks @alzhao that’s certainly quite a comprehensive list and it is encouraging to see the scope of your reviews. If the data collected can help identify the most common issues, it is very much worthwhile. I certainly don’t envy you trying to narrow it down for everyone’s Wifi issues, with so many variables.

Keep up the good work.


1 Like

Have a similar situation.

Am running on 4.2.2

2.4g repeater works fine but not on 5g.

1 Like

In my case I managed to fix the situation.

My MT3000 (firmware 4.2.2) was trying to repeat a 5G SSID off my Asus RT-AX58U (firmware

Settings as shown in the screen shot.

When the 802.11ax / WiFi 6 mode is set to “enable”, the MT3000 is able to connect, but indicates no internet.

When it is set to disable, internet connectivity works.

I have no issues repeating a 5g hotspot signal from my S21 phone set with Wifi 6


Very helpful indeed. Interesting that a GL.iNet router sold as running WiFi 6 is having compatibility issues with 802.11ax mode!!!

1 Like

We will got Asus router to test. maybe only have compatiblity to Asus.

We have Asus AX3000 device, played these same settings and MT3000 just work fine with it.

Our Asus firmware version is which is a little bit newer than yours.

1 Like

Have Asus RT-AX86U was able to extend the wifi to the MT3000 when on firmware 4.2 for the first time. After reboot of the MT3000 after 30 days up time, can connect to RT-AX86 but there is no internet.

Turning off WIFI 6 mode on Asus router, the MT3000 can connect to the internet.

Asus RT-AX86U firmware is

There is definitely a bug on the MT3000 dealing with wifi 6 mode.

1 Like

Using an RT-AX86S on firmware and experiencing the exact same issue with WiFi 6 mode enabled.

2.4Ghz works fine. 5Ghz says it’s connected but with no internet.

I’m on v4.2.2. Definitely disappointed, hope this can be fixed.

Try matching the Bandwidth & Channel to the same as the RT-AX86S.

GL GUI → Wireless → 5GHz Wifi → Bandwidth, Channel

having exact same issues.

1 Like

Hi, it has been months since you posted this, can you recommend a solution?

This is a long post, bear with me.

I am testing this at home before my holiday (or return for a refund)

I am using a very old router Asus ac88U (yep, without AX) , connected to the mt3000 via a very long lan cable into the mt3000 wan port configured as a repeater so it takes an IP from the Asus. So this removes the variable of the 2.4g or 5g handshake.

The mt3000 arrived on firmware 4.2 it was a disaster.

It refused to see all the SSID my phone could see. (like 10 others as I live in a high rise apartment.)

I tried protonvpn Wireguard it connected once and absolutely refused to disconnect. I had to reset the firmware.


I look forward to your advice.

  1. I should use the same channel number as the main router?

  2. You have suggested settings, such as the most stable channel number in Asia?

3. Do you have suggestion for a sim card 4G/5G modem? The Huawei E353 is not compatible.

The system kept telling me to upgrade to 4.2.3, ok, so I did it via online. After the upgrade…
(I am beside the router doing all the actions below)

I found out how to break the internet immediately. Just use ookla speed test on my phone. It will break the mt3000 for a minute. I guess it reboot?

I disabled the AX (then why pay for wifi6??) so the mt3000 wifi network will only support up to AC. This stabilize the network more but still, the wifi crashes when I do ookla speed test on my phone.

I also set the 5G and 2.4G to identical name and password. This also helped to stabilize connectivity but still cannot survive ookla speed test.

Later today, I will try to share a hotspot via my phone to rule out the Asus router variable.

Tbh right now, adguard or Wireguard is second priority.

@alzhao, at this moment I just want a stable wifi repeater (hotspot and cafe/hotel captive portal) to support 10 devices.

Are you using the original power supły? If yes, could you try another one that’s capable of 5 V/3 A?

@lecmipahu thank you for pointing this out.

Yes I tried a powerbank capable of 5v3a, I tried a charger capable of 5v2.1a, a fast charger QC3.0, and the original.

It must work with powerbank because that is how I want to use it on vacation.

I learnt something. The mt3000 will power on, does not mean it is stable. Mt3000 really needs 5v3a.

Now I am using a qc3.0 charger

Too bad it doesn’t work with your powerbank. Did it work with the QC3.0 charger?