Beryl AX - Repeater doesnt find any Wifi networks

I’m using a Beryl AX (GL-MT3000).
I have it for a while now and whenever I try to use it as a repeater, it cannot find any WiFi.
When i choose only 2.4GHz i can find some wifi networks but fails to connect.
It cannot find tethering from my phones both IOS Iphone and Android Pixel.
I have also a wireless router which I use in Greece and still cannot find the router.

The only way I can successfully use it is via Ethernet.
I’m using the latest Version 4.5.16
Wireguard Client is enabled. Wireguard Server enabled at home on another router.

I found similar tickets suggesting rolling back to 4.2.2 .
Also found some tickets mentioning changing country via Lucy. Bought the router from UK and use it all around Europe. I cannot find anywhere this setting. :frowning:

Any suggestions appreciated

go to advanced settings, log into LUCI, network, MTK Wifi and change the country of the adapter.

I had it to DE and, even if I reside in europe, some wifi ntw were not visible. I changed it to US, everything is ok now.

1 Like

Should Country be 00?
I found LUCI and Network and Wireless below are the settings:

Mode: Master | SSID: BERYL
BSSID: 94:83:C4:2C:C5:52
Encryption: -
Channel: 11 (2.462 GHz)
Tx-Power: 20 dBm
Signal: -256 dBm | Noise: -84 dBm
Bitrate: 286.0 Mbit/s | Country: 00

00 can be fine but don’t have to.

The best way is to adjust the country code to the country you are in - if this does not work, US might be fine.

Current setup is 00 but still Beryl Fails to find any WiFi networks while in Greece. Also there are no Advance setups for Beryl to choose a different country from Drop down. Found a video from GLinet showing how to change the country but that’s not applicable to Beryl.

Any suggestion how to change the country? With what value? or any other suggestions?

At this point not sure the country code is the issue because from a google search, e.g a Google Pixel hotspot usually is on Channel 6 so ideally should be visible with country 00

Just realized that the channels on my Bery Wireless Settings are preselected.
for 2.4GHz is channel 11 and for 5Ghz is channel 44. Can this be a problem? Should I change them to Auto?

The value must be ISO 3166-1 Alpha 2

So for Greece it should be GR

Make sure that the channel / frequency / encryption is something the Beryl can use.

Did you check the logfile? Maybe there is something odd in there?

Normally you should find something like “[…]found xx networks[…]”

Not sure how to change the country though. There is no dropdown on Advanced Settings for Beryl

Don’t edit the device itself, just the Wi-Fi configuration which is located under the device.


The value of the Country cannot be edited

Ah, my bad.

In that case 00 should be fine indeed.
Please try, while searching for Wi-Fi, locking to 2.4 or 5 GHz.

I locked to just 2.4 Ghz and a network is visible but fails to establish the connection. Will share the log later today

Also do you find any problem with the settings below?
Should I change the Channel to auto?

1 Like

Ok so in the end it worked without any change.
Not sure how or why but without changing anything I can see all the WiFIs and I can connect to my phones or my portable router which is great. Didn’t have to change the country or downgrade to a different firmware. All I did was a reboot, connected to LuCI, not specific change.

There seem to be some kind of specific issue with the wireless connectivity at my current’s accommodation router.

4 different networks worked except 1 which I can also use via ethernet.

Should that happen when the time is synced up though?

GL UI, time is synced up to your location, at the same time this should set the correct country wireless settings?

No.
The router does not know about the location, if you don’t select it.