Beryl AX - Speedtest failures - Router mode via Cisco switch

Hi Guys,

When I ran my original beta tests in December (4.1.2 release4) I had an issue with testing speeds via and when connected via ethernet to my (main) Flint router via a Cisco WS-3560CX-12PC-S switch. Basically, the first test runs fine then subsequent tests fail to complete using a Win11 desktop, Win 11 laptop or Android v12 & 13 phone. I’ve now upgraded firmware to 4.2.0 beta4 and tried again but I am having the same results consistently. If I connect straight to the router there are no issues - it works as expected. The Beryl AX has an out-of-the box configuration apart from being given a static WAN IP - no VPN, IPv6 or custom DNS settings.

The Cisco switch has a very basic configuration - all ports set to Auto, Full Duplex. MTU= 1500, no VLANS. I have attempted the same tests with my Slate AX, my old Beryl and Slate and I do not have this issue with these devices.

Please could you let me know if this is a known issue or if you’d like me to provide any log files.



What’s the issue behavior, could you give a screenshot?
How about turning off “Hardware Acceleration”?

Hi Guys
Sorry for the delay in responding - I’ve been away.

Disabling Hardware Acceleration has cured the issue for sure. I should have checked this first - sorry.