Beryl AX tcpdump missing most UDP packets

I’ve got the router in access point mode and I’m using Wireshark remotely with sshdump/tcpdump.

I can capture and follow TCP streams OK, but with a UDP stream tcpdump is only capturing approximately 1 in 200 packets.

If I ssh in manually to the router (rather than use sshdump):

iftop shows a fraction of the UDP rate I know to be flowing.

tcpdump -i br-lan -nn udp

…shows the same - only a fraction of the expected packets on the interface.

On another device upstream of the WAN port I can capture all traffic, and I know the WiFi client downstream is receiving all the UDP packets as I’ve got it acting as a UDP echo server and I’m getting everything back that I throw at it.

It appears that not all UDP traffic is exposed on br-lan - same if I try ra0

Am I missing something? It’s curious that some packets appear but most do not - usually with this kind of thing it’s all or nothing!

Try turning off hardware acceleration, which you can find under the network menu.

Thanks for the reply.

I am running version 4.2.1.
Under the Gl.iNet menu for network mode I only have the option to switch out of Access Point mode.

Under the Luci menus for network I can’t find an option for hardware acceleration either in the advanced device options or interface advanced settings.

Please can you guide me to where this option is in the interface? (Or SSH command to change it?)


That option is not presented for Access Point mode.

Edit: changed out of “access point” mode, turned off hardware acceleration as shown by @luochongjun, switched back into “access point” mode. The hardware acceleration option appears to still be applied even though the interface doesn’t show it - and now I can see all my UDP packets with tcpdump.

Thank you!

1 Like

This is very strange, your network menu is missing a lot of features, you can try to restore factory settings.

@luochongjun tried factory reset after upgrade to 4.2.2.
As soon as the device is put into Access Point mode the only NETWORK suboption is “Network Mode” - everything else is hidden. Is this a UI bug?

(I turn off hardware acceleration before putting into Access Point mode, and tcpdump works just fine for UDP capture).

What browser are you using and can you try a different one.

The same behaviour is observed in:

Chrome 113.0.5672.64 (64-bit)
Edge 113.0.1774.35 (64-bit)
Firefox 61.0.2 (64-bit)
Firefox 72.0.2 (64-bit)
Firefox 112.0.2 (64-bit)
Opera 98.0.4759.15 (based on Chromium 112.0.5615.165)

Are you able to reproduce there?

I noticed that you have set the router to bridge mode, you need to switch to router mode first to see this function