Beryl AX USB HDD Support

I have a WD 1TB HDD USB drive.

I had it plugged into the Beryl (not AX) for 2 years and it worked fine as a NAS (albeit a bit slow). No issues and was totally stable.

I have now replaced my Beryl for a Beryl AX, using the same HDD, and the drive is completely unstable. Sometimes it appears, sometimes it drops out. I see many differing errors in the log, nothing consistent, just errors and the drive drops out. If it’s helpful, I can capture some and post here.

Why am I having this issue when this same drive worked fine with the older model?

There is no external power supply to the HDD, just the USB connection.

Thank you.

I would still count on a power issue.

Could you set up an active USB hub in between Beryl AX and WD HDD? Just for testing.

Don’t have a powered hub to try. I hope that’s the issue as I will order a SSD and hope the power is not an issue for that. Its not clear why the USB port won’t supply the required power for a standard HDD when it has a USB 3.0 port.

Definitely a power issue. Seems (some, not all?) the Beryl AX have unstable or non-standard voltage supply or regulation at the USB-A port. Changing power supplies TO the Beryl AX does not help.
A powered hub or Y-cable will probably be your only options.

I had a similar issue where a 5G modem will not fully boot when plugged into the Beryl AX, however it works fine on the Slate AX (AXT1800).

What is a Y cable?

It would seem this would be a warranty issue then if the port is not working to spec.

A Y splitter cable. (examples) Much like a powered USB hub, but for a single device. Cable has 3 connectors, one for the host (Beryl AX in this use case) one for the connecting device (USB HDD) and one for additional power supply (which in good quality cables will be connected only to the USB HDD). You would, however, need either a multi-port power supply or a second power supply to connect to the HDD.

Have a Y cable on order to test in my situation.

GL.iNet staff have not responded to my similar question about warranty issue, I agree though it seems very much like the USB-A port in the Beryl AX does not meet the USB standard when under actual load (when nothing is connected it seems borderline).

1 Like

Thanks. Looking at those cables most of them appear to simply be splitters so two devices can be connected to a single USB port.

Do you have a link to one that actually does what you are talking about and will inject power from the third connector? I am not seeing anything that states it does that.

OK. I found one that is what you are talking about: ALINNA Black USB 3.0 Female to Dual USB Male Extra Power Data Y Extension Cable Splitter Adapter for 2.5" Mobile Hard Disk : Electronics

Thanks for the pointer. Will order one and see what happens.

1 Like

Just to follow up, the splitter cable connected to an additional power source allows the drive to work fine. So it is an issue with the USB port on the MT3000 not providing enough power.