Beryl - Connect on 2.4ghz, broadcast on 5ghz?

I have a Beryl at my camper, to repeat the campground wifi to the devices in my camper. In our monthly newsletter, the campground was saying lots of people are using wifi routers / repeaters, and that it’s impacting the campground wifi connection (due to many other broadcasters on the same channels), and I’d like to not be contributing to the problem.

Basically, I want to have the Beryl connect to the campground wifi on 2.4ghz, but not be broadcasting its own 2.4 network. I just want to broadcast on an unused 5ghz channel, so that I’m not contributing to the 2.4ghz problems at the campground.

I think I was trying to do this last summer, but may not have found the proper way to connect to 2.4 while also disabling the local 2.4 AP broadcasting.

Is this doable?

The camp ground should update their Access Points to better 2.4Ghz or 5ghz ones(Strongly encourage them to do so). Also they might not have the access points setup correctly. The could also be using a residential type router. The problem you are having is Co-Channel interference and some solutions are:
Physically relocate APs
Lower transmit power of the radio
Create a static channel plan
Move to using 5 GHz only, wherever possible
The two best ways for you would be to low transmit power or create a static channel plan. Lowering power can be done in the GL.iNet UI or LuCi.

Creating a static channel plan will be more involved and I believe it can be done in LuCi but more likely need to be done by SSH. You may want to try reposting on the OpenWrt forum

1 Like

To connect router to repeat wifi on 2.4Ghz and broadcast wifi on 5GHz:

  1. Turn on router to broadcast wifi on both 2.4GHz and 5GHz bands, with different SSIDs
  2. Connect a client device to router on the 5GHz band SSID and log into Admin Panel
  3. Connect router Repeater to wifi on the 2.4GHz band
  4. Go to Wireless page and turn off 2.4GHz wifi band, but leave 5GHz wifi band turned on

I do not work for and I am not directly associated with GL.iNet


Wait whaaaaat? When you turn off the 2.4GHz broadcast it still receives and repeats 2.4GHz. I thought Beryl when in repeater mode could not do simultaneous broadcast and transmit, took turns. When its 2.4GHz was turned off it turned the whole radio off.

So if the Connection changed Bandwidth because of interference how would it reconnect?

Yeah, this is the problem I ran into before (and yesterday when messing around with it)… If I turn off the 2.4 wifi broadcast, the entire 2.4 radio is disabled, thus losing the connection to the campground wifi.

Some more experimentation seems to be in order!

I do not have a Beryl, but it works on 3 different GL.iNet router models that I own.

If you use this snapshot firmware after June 13 GL.iNet download center
and still have this problem, I will file a bug.

You can also go to LuCI → Network → Wireless and only disable the 2.4GHz Master SSID.


I will have to give this a go when I get back to the camper next weekend!

wcs2228 Solution works on the Beryl never would have occurred to me to do it that way


It works, also I dug around in the luci settings to set some static IP config for the wan connection… I know I might have IP collisions, but seems like some of my network issues are DHCP related, when it fails to obtain a lease and ends up on a 169.x.x.x private address.

its because the beryl was the first to use a non open source chipset. the slate and routers before were easier with the open source chipset.