Beryl constantly rebooting

I have a new Beryl and I’m finding it very unstable. The system keeps rebooting. I’m using the stock power supply and I have a wired lan connection and yet I’m seeing that the system can’t stay up for more than a few hours.

Any suggestions on what I can look into?

Just to add to this, I’m running 3.211 so the latest version.

Can you just try another power adapter?

It should be the reason.

You want me to use an adapter other than the one that shipped with the router? I’m using the one that came with it currently.

Yes. Just try another. Because if the router constantly reboot is generally caused by the power adapter.

OK, so I ran the router at home using the stock adapter and it ran fine for days without rebooting. Today I’m using it and I’m finding that it’s rebooting on a regular basis. There are a few more clients connected today so maybe that’s a factor?

At the moment the router is useless to me for travel. Is it possible this is a hardware quality issue?

Have you tried with a different AC adapter as Alzhao has suggested? It does sound like an AC adapter not supplying enough power problem.

Since the problem already started when it was new, you should return it for exchange. It may or may not be a power adapter issue, but you should not have to pay to buy another adapter. If it ends up not being a power adapter issue, then you would have bought an adapter for nothing.

Even if you own another compatible power adapter, why should you have to use it to replace the stock adapter that is included in the purchase price of the Beryl?

I do not work for and I do not have formal association with GL.iNet

1 Like

Agreed entirely. You should not ha e to pay for a replacement AC adapter.

But I guess either you:

  1. Return the entire package and get a package that works but have down time but you’ll be without for the unit for a while.
  2. Try and trouble shoot and find the problem. If it’s the AC adapter you could reach out to gl. Inet and get them to send you a new adapter and still be to use in the meantime with your temporary working adapter.

No ones ever suggested they should wear any cost, just basic troubleshooting.

If you bought the router from Amazon or other good online retailer, they will ship you a new one and you can return the old one after. I think you already spent sufficient time on the old one. It is your decision.

It would have been better if alzhao had made the offer of Option 2 from the start

@jjross just get an replacement from Amazon should be fine.

So I just went on a long trip and tried my own Anker brand power adapter and it worked great. Uptime was days long with great speed and no connection issues.

I guess my power supply that came in the box is broken. Too bad.

It’s too late for an Amazon exchange or replacement so I guess I’m stuck.

We can send you a power adapter. For customer service pls write us an email.

Pls cite this forum post and your order number, you shipping address.


Submitted the request. Thank you.

I had the same problem with rebooting with my Beryl. The first problem, which was my mistake was that I was using a 2.5A rated USB-C cable and not a 3A. After changing the cable with a 3A, the problem wasn’t as frequently as before, but it was there. To solve the problem, I am using the following:

  • A well-known brand AC adaptor (power/charging brick) like Samsung, Anker, Baseus… that is over 15W (3A minimum, 5V);
  • A well-known brand cable with the minimum 3A rating. I am using a USB-C to USB-C from Baseus;
  • Firmware 3.203

Thanks. I also swapped Supplies and it’s been great.

1 Like