Beryl (GL-MT1300) - Cant get 4G dongle working

I currently have a Mango (GL-MT300N-V2) and i got this working with a - huawei e3372h-607 - in stick/modem mode & it works flawlessly.

My Beryl (GL-MT1300) arrived yesterday & i tried to get the same 4g modem working & followed the same procedure as (GL-MT300N-V2), however when i install ‘mod-usb-net-huawei-cdc-ncm’ the router freeze’s/crashes - the router remains on but the wifi is disabled & not accessible, the only way to get it functioning again is to remove the 4g dongle/modem and restart, then everything is working fine until i plug in the 4g dongle/modem.

I have tried starting the modem with the 4g dongle/modem inserted & have also tried inserting the dongle after the router is on, same result.

If i don’t install ‘mod-usb-net-huawei-cdc-ncm’, the router works, however the 4g dongle/modem wont connect to carrier.


1 Like

I will let developers to check.

1 Like

Perhaps related to my issues w/ 2.4G Wi-Fi going down when USB tethering to my MR1100 Nighthawk? GL-MT1300 Beryl - 2.4G WiFi not visible or not working - #2 by techhome

Hi alzhao is there any news on this?

Now it is two weeks holiday.

However you can try the snapshot?

Ok, with that firmware, it works with a 4g modem - thank you. One thing i cant get to work is, when connected to the 4g modem and i connect to a vpn client, internet stops on all connected devices, on the admin page it shows my VPN client is connected, however my devices don’t have any internet, do you think it has something to do with the interfaces i added to the network config to get the 4g modem to work?

Seems this is MTU problem again. Can you try other vpn services?

Can I get a copy of this snapshot (it is no longer in the link provided), I am having the same issue were the beryl is not detecting my huawei e3372h-607 ?

Maybe try the current beta: GL.iNet download center

1 Like

If all solutions in this post don’t solve your problem, read my post with the alternative details instructions for do it the trick and solve the problem: