Beryl (GL-MT1300) with UML290

I recently got a Beryl (GL-MT1300) to use with my UML290 Verizon USB Aircard. Looking at the Manual, it says the UML290VW (Verizon) should work with the router (confirmed tested by GL.iNet/steven). I saw someone else had a similar issue, but they moved to a different USB Card. What do I need to do in order to make the UML290 work? I have tried auto and it never connects. Doing manual and entering in the details (based on another mobile router I have that works with it) I can get it to connect, but it doesn’t have the USB Aircard details (like the IMEI) or get an IP Address. After a minute it disconnects and tries to reconnect with the same result (and just repeats this process).

Anyone have any thoughts on what needs to be done to make the UML290 work (manual settings, adjustments in the router, etc…)?

This is expected. The router does not read IMEI of USB modems.

Can you show your manual settings of UML290?

I can’t upload images (because the system will not let me). Below are the settings (everything is blank or default unless I call it out):

Device: /dev/cdc-wdm0
Auth: NONE
Proto: qcm
Dial number: *99***3#

It does connect, but it shows no IP and no data transferred.

Can you try qmi?

qcm is specially for Quectel modems.

qmi is not an option in Proto. Changing the Device from /dev/cdc-wdm0 to /dev/ttyACM0 does not change my Proto options (which is auto or qcm). Changing to Auto doesn’t resolve the issue either. If anything it makes it worst as it never actually connects (where the qcm connections, but I don’t get an IP).

Can you do this, choose cdc-wdm0 and auto, then ssh to the router and change the proto to qmi in /etc/config/network.

You can also use winscp if that is eaiser.

I set the GUI to be Auto with cdc-wdm0 as the device, and modified the config as requested. Still does not connect (doesn’t appear to attempt like the qcm did). Below is the config from the network file:

config interface ‘modem_1_1’
option ifname ‘wwan0’
option service ‘umts’
option apn ‘VZWINTERNET’
option proto ‘qmi’
option device ‘/dev/cdc-wdm0’
option node ‘1-1:1-5’
option dialnumber ‘*9***3#
option auth ‘NONE’
option metric ‘40’
option disabled ‘0’

wwan is set to proto DHCP and metric 20.

If its helps, the UML290 uses a Qualcomm MDM9600 chipset, as can be seen in FCC internal photos:

I do not work for and I do not have formal association with GL.iNet

Did you restart the router or network?

/etc/init.d/network restart

At the time, no. I have booted it back up (so it has been offline since I changed the setting and last tested) and it did not make a difference. With the qmi settings, it still does not connect.

@alzhao or anyone get this to work? the docs say it was tested and works but can anyone provide a full working configuration?

No, although the Aircard is now not working in my old router now or in a computer with the software. I might need to try and reset it some how.