Beryl (MT-1300) Some Apple Time Machine Issues (ext-Root + Block-Mount + Samba4)

Attempting via a GL-MT1300
Currently using the prebuilt GL firmware 3.215 w/ OpenWrt 19.07.8.

Willing to attempt by running a clean install of OpenWrt 19.07.8 → 22.03.02

Or, the Beta release.

First off, Hi :wave: I’m new here but willing to learn and earn some good karma!

Currently my goal for the device is to use it as a portable modern day “Airport Time Capsule” for a MacOS computer with an ext-Root partition hosting (adGuard/adBlock) on a SD card.

  • I’ve accomplished so far in separate instances but never together :face_with_raised_eyebrow::
    • Getting the device to read and write to a USB (sda1) Master Boot Record formatted HFS+ drive this works for all instances below. (:trophy:)
      • Creating an ext-Root on a SD Card (mmcblk0p1) in a EXT4 format with an installation of AdGuard Home/AdBlock just to confirm new overlay works.
      • Creating a samba4 based Apple Time Machine that connects to macOS via (SMB). So far works with (Big SUR → Monterey → Ventura)

ISSUE #0 (Block-Mount)
After an accidental loss of power (Unplugging power cable)

  • The router losses write access to the HFS+ USB (sda1). This of course cascades to Samba4.
    • Somehow this returns the USB (sda1) back to a read only device. Even with it set to force,rw,noatime in mount options.
      • FIX so far I found unplugging the USB from the router and connecting it to MacOS. And, running first aid on the volume in disk utility. Then reconnecting the USB to the device followed by a reboot of the router.
      • While this does work It’s not ideal. I rather the router “run first aid” on the USB + remount it as a read/write partition.

ISSUE #1 (Block-Mount + Samba4) “Rare chance”
After an accidental loss of power (Unplugging power cable)

  • The router automatically sets the HFS+ USB to (sdb1).
    • FIX log into the luci and reconfigure the drive back to /dev/sda1.
      • While this does work its not ideal. I rather the device set any USB plugged in as (/dev/sda1 /mnt/sda1) automatically
      • Or, recognise the “timeMachine” USB always as (sda1).

ISSUE #2 (Block-Mount + ext-Root + Samba4)
I’ve gotten ext-Root to work, migrated all of the packages over to the SD Card (mmcblk0p1).

Unfortunately, when I list the actual mount location (Path ->) of the USB (mnt/sda1) in samba4 it does not appear via SMB this goes for any USB sans format.

  • I’ve tried setting it to /mnt/sda1 I can definitely find the USB there when I SSH into the device location with read and write privileges.
    • I think it’s true location is somewhere else on the system due to ext-Root. :thinking:
    • Or, ext-Root even though it’s hosted in the SD Card. May be interfering with samba4 as it’s now in a SD-Card instead of the usual standard USB drive.
      • Could use some assistance on keeping samba4 on the devices internal memory while establishing an ext-Root to host packages like AdGuard Home/AdBlock.
      • Or, finding the true path of the USB (mnt/sda1) location.

TL:DR/Summary
I’m currently documenting my notes on how to recreate this on device from scratch to be submitted for review. Post completion and a brief stress test.

I’m not ungrateful, but I’ve noticed a lot of the guides are deprecated and some solutions are spread out via multiple sources/websites. And, because of this I was inspired to leave a slight mark here as good karma. But, I need a bit more professional support…

If you have any questions, comments or concerns. I’m happy to provide content! :grin:

And, would really appreciate it if individuals lists options and solutions to each issues via the (#) number above. I’m new•ish to programming. But, dedicated life long learner.

And, again thank you for your time. :pray::star_struck: I’ll be checking this forum post periodically.