Beryl MT-3000 Repeater

Hello,

I recently purchased the Beryl MT 3000 router to use on travel.

I connected it to my home wifi, to test it, and it worked great. Firmware version was upgraded to 4.5 and I had no issues.

I travelled, and used it at my hotel, and had no issues. Captive portal worked and I was happy with it.

I returned home, and the router now will not reconnect to any of my home wifi signals.

I tried resetting the router, rebooting, upgrading to the 4.6 firmware (I think that was a beta version - but I’ve since reverted back to 4.5). I tried deleting all the “known” Wi-Fi’s and tried re-entering the info…

Nothing works in repeater mode. It just does not connect and then it times out.

How can I fix this? It worked really good until I took the trip.

1 Like

I also experienced this recently. Can you check in LuCI which country the radio is set to? It’s should be in NetworkMTk WiFi. Mine was set to a different country. I had to set it to the country where my router operates in.

If you’re connecting by WiFi and you have a dfs signal selected you need to wait for the router to complete the radar scan before it’ll allow the signal broadcast. Up to 10 minutes.

If your connecting by ethernet then make sure you’re assigned an IP and address the top of the chain, eg 192.168.8.xxx means you address 192.168.8.1 to contact the router.