Beryl MT3000: Unable to set the MAC address

I just received a Beryl AX3000 and found that if I set the MAC address before I connect it as a repeater, the MAC address I have set disappears and it goes back to the default.

Furthermore once I have made a connection I can no longer set the MAC address, I get an error that flashed briefly at the top of the screen:
Unknown network error. Please check the network environment or reboot the device.

Disconnecting the router from the network, disabling WiFi, nothing I found permits setting the MAC address. I need to do a factory reset to be able to set the MAC address (although as I mentioned doing so is useless because as soon as I connect my MAC address is wiped out).

Btw: First thing I did was update the Beryl (to 4.1.3).

Is this a bug (it works for my other GL.inet routers)?

Will upgrading your Beryl AX to firmware 4.2 solve this problem?

No, it did not. I see that the interface for setting the MAC has changed from 4.1.3 to 4.2.0(beta) and both are different from that in your other routers. I find it more confusing in both 4.1.3 and 4.2.0, especially so with 4.2.0. For example the AC1200 shows this:

The 4.2.0 beta this is now three tabs, “Factory Default”, “Clone”, and “Manual” like so:
*** FACTORY-DEFAULT tab image I tried to insert here but cannot cause I’m too new a user ***
*** CLONE tab image I tried to insert here but cannot cause I’m too new a user ***
*** MANUAL tab image I tried to insert here but cannot cause I’m too new a user ***

The original interface (AC1200) was more clear what was going on. Factory Default I get, but I’m unclear on the distinction between “Clone” and “Manual”. Also the designation of “Ethernet” vs the older “WAN” makes me wonder what I’m setting the MAC address for. WAN is clear, but what is “Ethernet”?

Regardless, it does not work in 4.2.0. I still have the issue that it resets the MAC address after connecting and does not permit changing it after the first attempt. I’m sure the images make all of that clear.


We have tested it on both versions and it does not reproduce the issue you describe.

Please refer to the Internet page for the interface name. In Factory Default, the MAC address provided by the device to the Ethernet cable and the MAC address provided to the hotspot on repeat are different.

It looks like the repeater operation has disconnected the client from the router’s Wi-Fi connection. Have you confirmed that the client has reconnected to the router?

Same here, no way to change mac address on the wwan…
Is there a known fix please?

Thank you!

They just released 4.2.0 release 1 and that fixed the issue for me. In find the GUI confusing, I expected “Clone” to be where I made a different MAC address (it is not). I went to “Manual”, typed in the MAC address I wanted to the “MAC Address (Ethernet)” field, and hit “Apply”. Previously that did not “stick” across a reboot for me, now with this last Firmware it does. I also find it confusing that the textbox where I enter the desired MAC address changes away from what I set, I have to look below in the “MAC Address (Repeater)” field to see the proper value.