Beryl not allowing connections to 2.4ghz

I have a brand new Beryl. GL-MT1300, current firmware 3.215 snapshop (tried 3.211 as well).
Brand new. I cannot get any devices to connect to the 2.4ghz network.

I tried lots of different settings, none of them changed anything.

This is the luci log I get when I try to connect:
Tue Aug 2 00:06:47 2022 kern.warn kernel: [ 1525.850013] BcnCheck: no bcn occurs within 10 sec for band 0(ra0)!!
Tue Aug 2 00:06:47 2022 kern.warn kernel: [ 1525.850013] debug info dump as below:
Tue Aug 2 00:06:47 2022 kern.warn kernel: [ 1525.850013]


I am using a Beryl on my desktop now.

2.4G is OK.

“Any devices” include your laptop, right? What are your settings for the 2.4G wifi? can you share?

Yes, literally no device can connect to the 2.4ghz. we first found this problem because I offer free internet and we had a group of half a dozen people standing around with multiple different phones and a computer and none of them could connect to it. Since it started I’ve reset the modem, and tried multiple different firmwares all the way to the 8/2 snapshot without any change. The 5ghz works fine.

I tried the same and I could connect just fine.

What kind of other settings did you make?

Can you do a firmware reset and try agian?

I’m operating 2 Beryls myself, never faced an issue connecting anything to 2.4GHz WiFi but I always use the ‘most versatile’ settings.

So my advice was to set

  • WiFi mode to 802.11bgn
  • Bandwith to 20/40 MHz
    both give you a broader range of supported devices
  • channel to auto
    avoids congested frequencies


Same issue no matter what settings I use. I’ve reset the unit multiple times and upgraded/downgraded the firmware repeatedly. At this point I’m starting to think that perhaps the 2.4 gig radio is simply faulty. :man_shrugging:t3: