Beryl problems

My Beryl constantly drops connection to the internet. The light on the front goes from steady white to a slow pulsating flashing blue. It does this at least three times as day. When it does I’m unable to log into the settings via the advertised ip on the base of the router or the address given by my network. I have to pull the plug and reset to get it working. There’s no issue with my WAN/LAN as when I take the cable from the WAN port and plug it directly into a device it works fine. Plug it back in and the router just flashes blue and I can’t log in. Any thoughts? The speed also fluctuates, can be anywhere from 12-69mbs where other devices that don’t use the Beryl hit a stable 75mbs.

So having been logged into the settings and the problem happening again the home page says no cable detected in WAN, if I pull the cable and plug it directly into a device the connection is fine, if beginning to think I might have a defective Beryl with a WAN port issue, but not being able to log into the router while the lights are flashing blue is also a concern.

1 Like

Is the WAN just dhcp?

Did you set something else, e.g. vpn and vpn policy?

Can you get the system log?

Hi, yes the protocol is DHCP, I’ve no VPN running while it drops the connection. Seemed to be okay for a few days and now it’s back to doing it. How can I get the system log? Can’t see an option anywhere. It also gets quite hot underneath, and now the router freezes if I run a speed test, it hangs on the upload test, requiring me to pull the mains cable.

You can ssh to the router and use logread to get the log.

Did you ever figure out what was causing the Beryl to do this? I have the Beryl as well and it does the same thing to me no matter what I’ve tried it continues to do it. The only workaround I’ve found is turning it into an access point instead of a router and that’s not okay by me. I bought it to use as a router.

1 Like

MT1300 3.211 firmware has fixed various bugs. Have you tried?

I’ve already done the firmware update date it didn’t help anything.

1 Like

Five days ago I installed 3.211 stable (keeping settings during upgrade) on two Beryls I have and stability improved a bit. They were hanging about once a week.

Both Beryls have the same setup, among other things including: Wireguard server connected 24/7 with a separate 750S (Slate) in client mode, plus my laptop from time to time. Registered with GoodCloud. Not using GoodClouds VPN function, just plain old WG.

Today, while turning off/on back and forth the wireless networks (was testing wifi “failover”) on router A, (I was connected remotely on WG), it suddenly became unresponsive. It was unresponsive for about 1h and then suddenly I received the notification from GoodClound that it was online again… so I guess it auto-restarted. That’s not very good news but at least I didn’t have to go to the office to power cycle it as before.

So, seems to me that 3.211 at least self-restarts (purposefully or not) - at least I never saw that happen before.

I have factory reset Router B today and reconfigured with the same setup from scratch. Will keep an eye on it for hangs. That would tell me whether carrying over old settings is part of the equation.


Can you give specific description? I cannot help for “it didn’t help anything”.

It is running the most recent firmware, yet it goes from solid white to flashing blue several times a day. It is connected to an M1 in DHCP mode no VPN, connected via an ethernet cable to WAN on the Beryl. There are often times that it shows solid white on the Beryl but it’s still unable to connect to the internet via the Beryl. I can turn on the wifi on the M1 and it connects perfectly, or I can wire it straight to the M1 and it works great that way as well. I’ve tried resetting the Beryl but it hasn’t helped. When there is no internet it still shows connected when I log in online to the Beryl. The only settings I changed were adding iptables TTL in the custom area of the firewall via Luci. If I need to run a log or specific test please leave step by step instructions on how to do that.

1 Like

I never fixed the issue on mine I ended up selling it on eBay and buying a GL-MV1000, which works flawlessly

1 Like