Beryl USB iPhone Tethering not working

Hi, I’ve recently purchased the MT1300, Beryl, router. I’m having issues trying to share my phone’s data with my router via USB tethering.

I have an iPhone 11, running iOS15.1. When I try to connect, I simply lose connection to the router and when I log back in, the tethering has not worked. Oddly, I also have a work iPhone 7, also running iOS 15.2, which works perfectly.

I can’t see anything obvious as to why this is not working - does anyone have an ideas?

After you set up tethering (click connect on the router UI), wait several seconds and if the iphone does not show connected, pls try

turn off hotspot on your phone
wait 5 seconds
turn on hotspot again

Thanks. I’ve just tried this multiple times, but I’m afraid it hasn’t worked.

I don’t suppose anyone has any other ideas? I’m still unable to get this to work and this was my primary use case for the router.


I have similar issues with my MT300N Mango. Here’s my steps which normally work.

  • Turn off personal hotspot.
  • Turn off wifi and bluetooth - Important - do this from the main control panel, not the swipe down control centre which doesn’t actually turn the radios off.
  • Turn Personal hotspot back on. If/when requested just allow USB tethering.
  • Connect IPhone to router.
  • Approve the trust computer request (this should happen and is a good sign).

Sometimes doing a quick toggle of the hotspot (allow other to join radio button) can help too.

1 Like

This is not working for me. I used to get the “Trust/Don’t Trust” pop up but I no longer see this. Like the original poster I’ve got an iPhone on the latest iOS version.

It definitely works when I try a USB dongle instead of the iPhone so there’s an issue with the tethering with the iPhone itself. Note: it has previously worked for me and now doesn’t.

Update: I’ve also tried resetting the trust settings and I get the trust/don’t trust pop up. Made sure to click “trust” but then, again, tethering connection doesn’t work.


I have the same problem with an iPhone 11 (SW 15.0.2) and a Spitz router.

I’ve already used different cables, switched hotspot on / off several times, tested various instructions from the forum - the problem still exists!

When I connect the Spitz to an Android (Pixel 4a), tethering works.

Is there a solution ?

OP is not using phone hotspot, he’s using USB tethering.

I may have expressed myself incorrectly.

In fact, I switched the “personal hotspot” function on / off several times on the iPhone.

In addition, the tethering function on this iPhone already worked flawlessly a few days ago.


OP here. I just wanted to report back that I tried again to plug in my phone, and it has suddenly started working. I have no idea how, but very happy it is now working.

Thanks for everyone’s help on the thread.

1 Like

Just to add my two cents, I discovered with some help from tech support that not only do you need to connect the tether and turn on the iPhone hotspot, but you need to log into the router and first disconnect any other tether connections, then connect after attaching the iPhone. This was not evident at all to me when trying to switch from a tethered Android phone to my iPhone.

Unfortunately iphone and andriod are different and you need to set up again.