Beta Firmware dmaged WAN Port

I have upgraded my modem to the latest beta firmware as of today. The modem functioning fine. However, when I click switching the WAN port to LAN and plug in my cable into the port it does not work anymore!

I tried flashing different firmware versions, yet nothing got the WAN port to work!

Then, I tried flashing through the Uboot process, but the same firmware still unchanged with all my settings. The Uboot I have on my modem is compiled in 2023 March with code rc7.

Should I ask GL for a replacement or are there any other steps I could do to verify whether the port is physically damaged?

I use this modem for work and study, so I kindly need a fast response from GL engineers. I should mention that I am currently connected to the LAN port without issues.

It’s so unusual that a modem gets hardware issues for less than a year of usage! I advice everyone Spitz X3000 owner to refrain for now from upgrading to latest STABLE/BETA firmware since they are the same file!


  • trying the WAN port after getting into the Uboot page, still not working.
  • The LAN port is about to die as well since I am getting triple the speed on my phone at the same postion, and usinbg the same 5G provider.
  • I flashed it with the compiler’s auto-generated firmware, still no luck.

What happens when you reset the device to delete all settings?

it does delete all settings.

Aaaand then the port is alive again?

No. I already mentioned that even trying different firmware versions, which imply the settings being deleted.

So the port is even dead in WAN mode?

Yep. I tried to run DHCP server on my computer and connect the modem to it in WAN mode still not getting IP.

Does the link got established? I mean on Windows for example you can see if there is a connection on the line - even without DHCP. Shows the LAN connected there?

If not you should mail the GL service and mention this thread. Refunds / Replacements are usually not done by the community forum.

1 Like

Guess what?! I connected to a Windows laptop and the port got working without any problems! It appears that my both Linux boxes were updated to unstable network driver that refused to work with the wan port at all!!

You’re the man ! Good night :zzz: