Black 750s?!


#1

IS that a Black 750S with dual external antenna and GBE? and usb3.0? in the new pic on the main page!? please say it is?!! I’ll gladly test one if you need testers!


#2

it is usb 2.0

Other things are correct.


#3

Ooh, I want one already! My main goal is to take it with me traveling (WISP) and get a good signal even when the hotel WiFi isn’t close, with a reliable connection that doesn’t drop (which I’m assuming I could have by using the two bands separately, one for connecting to the host and the other for my guests). This sounds like the ticket.


#4

Any reason that you want Gigabit Ethernet?

Hotel WiFi never exceed 100, maybe just 10mbps


#5

@alzhao i don’t think he meant the gigabit part. Some routers are able to set up one radio, 2.4ghz to connect as WISP, and then have the second radio 5ghz, as the access point, bridging the two. This way the speed of the WISP is not reduced to half as usual with just 1 radio.


#6

That’s actually not true. I travel quite a bit for work and what often times ends up happening is you pull the cable from say a Netflix box or something, and then you create your own network off of that. Those lines run 400mbps+.


#7

That’s right, for my use case you are totally correct. I know there is a lot of demand for gigabit but I have no need for it in a travel device. I’ve found the WISP mode of previous devices to be very unstable, and I’m hoping that dual radios will solve that (especially if I use one radio for the host and one for the client). My priorities are stability and range (plus the convenient software and VPN support which all of your devices offer).


#8

I’m using the new GL-B1300 with two radios. I’m in the hotel now. There is an Open attwifi network here. It’s a solid hotspot connection right outside the hotel door. I can connect just fine on the laptop hit the captive page, accept the terms and be online. Then when I directly connect ethernet to my GL-B1300, turning off laptop wifi, I set up the repeater to connect to the same hotspot, it connects, I can see my IP address from the hotspot on the admin page of the router, but no route. and I never hit the captive page. I even tried cloning my wifi mac from the laptop to the router, connects, still doesn’t go anywhere. I’m not sure what I could be doing wrong exactly. But it’s very frustrating.


#9

@unio, you are way off-topic -delete and try opening a thread yourself.


#10

Uncheck dns Rebind protection in custom dns settings and try again.


#11

I blame the ATT hot spot the hotel was using its portal was very flaky
I did get it to work
But it failed many times before I managed to make it work.


#12

Can’t wait. Just saw the new product page. When might pre-orders begin?


#13

@unlo

Thank you for taking interest in GL-AR750S! You can click the following link to sign up for the early reviewer program and we’ll keep you informed with all the news about the product.

http://eepurl.com/dztzhX


#14

Anyone who is interested in buying Slate (GL-AR750S-Ext) router, you can pre-order the device here: https://store.gl-inet.com/pages/slate-gl-ar750s-ext-gigabit-travel-router Early bird deal is available but we only have a few offers left. We will start delivery to early bird buyers in early August 2018.:relaxed:


#15

Heh. Yeah, I do that sometimes too :slight_smile: … plus, sometimes those lines don’t require authorization nor payment, either (but I’m top-tier in most of my hotel chains and get the good stuff for free anyway).

But yeah, that being said, 100Mbit is all you need most of the time for travel.