Blocking External DNS servers

I’m experiencing problem using updated Netflix app on Nvidia Shield TV where it is detecting that I’m using a smart dns proxy (on B1300 router). I have set manual dns server and disabled clients to use their own DNS server but still it didn’t work.

Anyone had same issue and resolved?

Did you turn on the Override DNS Settings for All Clients option?

Yes, as I mentioned I have but still it didn’t work.

Is your B1300 directly connected to the public network?
Is there any other router in between?

I’ve seen some Smart DNS providers recommending that you set up static routes on your router due to the fact that the apps are hardcoding DNS

Has anyone managed to get Netflix working on any smart TV / streaming devices - such as Fire Stick? - as I beleive this is the case with all of those devices.

No there is one router before it which also has same dns server defined. Should I connect directly?