Brand new AXT1800 keeps flashing blue light and resetting

Did I get a malfunctioning unit? This is a brand new AXT1800 out of the box, no modifications. This is the pattern it’s exhibiting from an off-state when I power it on:

It hints a white light, then turns stable blue. Then it starts slow flashing blue for about 10-15 seconds, and it shuts off. Then it repeats the cycle all over again. White (0.3s) > Stable Blue (5s) > Flashing Blue (10-15s) > Repeat. At no point does it ever appear under my network in any of my devices.

I’ve tried factory resetting (don’t know what good that’ll do since it’s already brand new…) but it didn’t help. I’ve also tried several different power adapters, just in case the one included in the box was busted, and they all exhibit the same behavior, so I’m pretty sure it’s the device…

Hmm you are sure you haven’t a ip conflict with the modem its connected to?

Tested with wan port connection to your modem aswell?

It seems that the router kept rebooting. The LED shows a normal boot cycle.

If not the power adapter, it must be firmware.

Have you set up repeater? If yes then it seems you met the 160MHz bug.

So need to reflash the firmware using uboot.

Pls use the 5.4 kernel firmware which does not have the 160MHz bug.

Reflashed using uboot to kernal 5.4, it is now operating.