Brand new Slate AX stuck in firmware loop

I got a brand new GL-AXT1800 / Slate AX. I plugged it in, saw the WiFi networks it broadcasted, tried to connect, and couldn’t get to the admin page. I tried a few different browsers with no luck. I decided to unplug it and plug it back in. After that I couldn’t see any WiFi networks.

First I tried to do a reset by holding down the button on the side, but that did not seem to make any difference. Then I followed the instructions here to update the firmware using UBoot. I downloaded the 4.5 firmware, got to the firmware update page, uploaded the firmware file (.img), and started the update.

I see the router flashing blue, then the LED turns off (restarting?), slowly flashes blue 5 times, and then is solid white. I can never see the router’s WiFi networks and if I ever go back to 192.168.1.1 I am back at the firmware upload screen. I’ve tried with MacOS and Windows. I’ve tried different versions of the firmware back to 4.0.3.

I’m ready to send it back and get a new one, but I figured I’d start here. If anyone has any ideas, please let me know!

Usually the gateway ip for gl-inet products is 192.168.8.1 for u-boot its indeed 192.168.1.1 but only through static ip configuration.

Also there are two u-boot urls, the site with a appended /uboot.html and without the appended page.

Never use the appended url because that is to update u-boot and can actually perma brick the device only in rare cases it was needed for example the Flint 1 which had some issues with getting the ports up im guessing for new flint 1’s thats not needed anymore but i haven’t confirmed that, these images are also different than the dl site, so if you url was without it, thats fine thats the normal u-boot process :+1:

Also if the router is not first time setup yet there will be no internet connectivity, there will be lan connectivity still.

My guess is to check it via ethernet and then wifi once it has been setup :wink:

Yes, I set the static IP and used 192.168.1.1 to try the UBoot process (without /uboot.html). I used a firmware file that I downloaded from the main download site.

I currently have the router connected over ethernet (and my WiFi is turned off so that is the only connection). I turned off the static IP and am using DHCP again. My IP is set to 192.168.8.2. But I still cannot get to 192.168.8.1.

Can you ping 192.168.8.1 or even SSH into it?

I tried to ping 192.168.8.1 and it just times out.

I tried to set my IP back to 192.168.1.2 and then I could ping 192.168.1.1. But nothing I tried let me ping 192.168.8.1 (static IPs, DHCP).

If the router is serving up the 192.168.1.1 UBoot page, would it also be possible to have the 192.168.8.1 interface? It seems like my router is always in the UBoot phase even after I update the firmware. It feels like the loop is:

UBoot → Upload Firmware → Write Firmware → Auto Restart → UBoot

Might be a problem with the firmware file then, maybe the fw was not written correctly.
You should try again and power off and on again the device after the flash progress

1 Like

Thanks @admon for your help so far!

I tried again with powering it off/on, but every time it turns on it seems to just be waiting for the UBoot process.

Just for additional information, the reset button does not seem to do anything.

I’ve tried on a Windows machine and a Mac. On the Mac, after the firmware update and the device restarts I set the Ethernet settings back to DHCP. In this case I get a IP address of 169.254.x.x address, so it seems like I can’t even get an address from the router. I did manually set the IP to 192.168.8.2 just to test, but I still couldn’t get to 192.168.8.1.