Bricked AR300M unable to update uboot to latest version

I bought an AR300m on ebay. The seller claims he tried to upgrade to latest firmware version and it went into an infinite reboot loop. He then tried to upgrade via uboot and failed so he decided to sell as is and I bought it. The first thing I tried to do was update uboot to get the latest version loaded on the router. I got the latest uboot from github. Then I went to to update but I keep getting an error saying wrong size and whatnot. I did get the .img files from the gl.inet downloads page. Besides failing to update uboot, I get the same error message trying to upgrade the actual firmware from the uboot menu at Is there a way I can force install the firmware and unbrick my AR300? Thanks!

Which file did you upgrade, please? Can you provide some screenshots or logs of the error messages?

Sorry, I have been very busy at work this week. This is the message I get when trying to update uboot to latest version. I also get the same message when I try to update to the latest firmware on the current uboot at The router doesn’t boot at all but I can get to uboot.

Are you connected to a serial port, and if so, can you provide logging information for the serial port?

I don’t have a cable to connect to the serial port, when can I get one? Only to the LAN port. I’m following the uboot instructions and that was the error I received. I’ve flashed previous gl.inet routers using uboot but never had this error before.

Reading other threads on this forum, I noticed my uboot page doesnt display the version on the bottom like it should. Could I have a wrong uboot installed?

This is a very old version which uboot cannot be upgraded itself.

If uboot cannot be upgraded, how can I at least install a working firmware version to be able to use the router? Thank you.

1 Like