Bricked Beryl MT1300

I tried installing a customized openwrt on my new Beryl, When I did go to uboot screen I uploaded a file (definitely wrong file) then clicked install but it went black and now there is no lights on my router and I tried again getting to uboot several times but since it has no lights I cant get it to work.

What should I do?? Please help

Did you replace uboot with a customized one?
How about the wrong file size and page to access uboot web(

Please provide more details to help debug.

I uploaded a wrong bin file and then the router LED went dark and I no longer can access uboot.html

Could you share the wrong bin file for test?

It was one the bin files from GitHub - gl-inet/uboot-source-for_mtk: U-boot for GL MT300A GL MT300N-V2 and so on, which are based on MediaTek SoC.

So it’s caused by flash uboot by a wrong file. Why do you want to change uboot?
Only reflash the nor flash chip is possible to recovery then. :exploding_head:

My mind must have been in a another world, is there any solution to recover from this state?! or is it dead?

If you updated the wrong uboot, it is over.

Thank you, RIP new beryl

Good to know, there is no other recovery possibility. I really have to remeber this: NEVER flash a wrong uboot file. Triple check if it is the right uboot file.