Bricked S1300

Hi,

I built the software and followed the instructions here:

But the firmware it built bricked my S1300. I opened the box and used a serial console (ground, Tx, Rx) on the board successfully before it was bricked, but now when I turn on the power no light turns on and nothing comes across the serial console.

Is there a way to reflash or repair the device, or is it now permanently bricked? Even returning it would be better than nothing, but ideally I’d like to be able to reflash it somehow. I have advanced development hardware for flashing firmware and running a serial console.

Thank you!!

I figured out (in another post) how to make imagebuilder generate a successful image: Success Path to Imagebuilder OpenWRT for S1300

So, can you confirm you solved the problem by using imagebuilder to make a compatible firmware?

No, I still have a bricked device. I bought two. Building with imagebuilder works on the second device but I would still like to unbrick the first device.

Also, I still don’t know how to successfully install from source here (github tree gl-inet/openwrt/tree/openwrt-18.06-s1300). I can’t post a link because the forum thinks it’s spam. I have completed the configuration and compilation but am afraid to install it because I am afraid it will brick my second device.

So, I successfully installed the factory/openwrt binary and compiled image from your source, but after rebooting it the LEDs don’t turn on. I bought another device and followed the instructions and now I have the same problem. I tried the instructions at https://docs.gl-inet.com/en/3/troubleshooting/debrick/ but the LEDs don’t turn on and nothing comes across the UART serial console either. Can you help?

@hansome can you pls have a look.

Really sorry for following up on your issue so late.

Do you have equipment for soldering and a nor flash programmer? I can send you a flash image.
If you don’t have tools to reprogram nor flash or you’re not familiar with that or you don’t want, please return them back.

No problem. Thank you for the reply. This is a weird one.

I was planning to use the Bus Pirate for this, using something like described here:
http://konukoii.com/blog/2018/02/13/lifting-firmware-with-the-bus-pirate/
But if I need a different programmer I can get that.

I can also solder if needed.

You can reply to me here on the forum with the flash image, or to an email I sent to support@gl-inet.com. Also the specific pinouts with respect to reprogramming the part would be helpful. Thank you very much!

Happy new year and best wishes for a successful 2020!

1 Like

@hansome i have a similar issue wih a AR150-EXT. I don’t believe its bricked but i do have jumper cables to flash the bios chip. I can’t connect to the device any other way as far as I know. The LED lights do turn on. Unless there is a way to flash it using the USB port but I’m not sure how to do that. I’m using Fedora and when I connect them via USB I don’t detect the device. Is there a driver I need? This happened when I tried to flash a custom firmware .bin while connected http://192.168.8.1 but then the SSID wasn’t visible and I was no longer connected. I tried to hold the reset for the 3 and 10 second time periods and still nothing.

Please check this link to debrick ar150. If the led react to reset button push when plug in power, the it can be recovered this way.