Brume 2 - google search is very slow when Hardware Acceleration is enabled

Hi there,

Just received the Brume 2 and ran the initial configuration.
After the initial setup I started noticing delays when doing google searches (mainly if they were done in the address bar). and were very slow too.
After some testing I found out that the issue was related to the Hardware Acceleration option, which by default was Enabled. After I disabled it the problem disappeared. Enabled it again and the problem returned. I ended up letting it disabled as the internet becomes unusable if Hardware Acceleration is enabled.
Is this a known issue for Brume 2? If you want me to do some tests or whatelse to show you the issue happening, let me know.


Is the brume 2 the DHCP server?
Could the Ip or subnet be conflicting with something else?

Iperf3 is a better test of device speed and can show cpu utilization

I do not get any delay or slowness with Hardware Acceleration enabled on my Brume 2. I cannot think of how it could only affect specific websites.

Can you check/post your System Log for errors/warning?

I do not work for and I do not have formal association with GL.iNet

Yes, it is the DHCP server.
I don`t believe it is conflicting with anything else.

Just to share what I did, I had a Brume 1 as, devices in the range to 254.100 to 254.
Just configured the new one as and replaced the old Brume by the new one as the main router, so all the devices now are in the range to 254

Anyway good to hear @wcs2228 saying his Brume works fine with the Hardware Acceleration enabled. It must be something with my network then, I will do some more tests and see.

I tried mine and I don’t have this problem.

If you say there are problems with speedtest and fast, it is generally related to vpn and mtu.

Are you connecting on 4G networks?

Are you using vpn in any way?

VPN is not enabled.
Connection is fiber, 300Mbps.
Config is pretty simple, modem in Bridge, Brume 2 doing PPOE connection, DNS set as Manual/Cloudflare with no encryption, IPV6 enabled (NAT6/Automatic) and Hardware Acceleration enabled in Network area. Everything else is untouched. It is the same config I had in Brume 1, only difference is the Hardware Acceleration option that did not exist in previous version.

I think I found out what triggers the problem…it happens when I have both Hardware Acceleration and IPV6 (mode NAT6/Automatic) enabled at the same time.
If I disable any of them it works normal, it looks like these 2 features are not working together fine.

There is this note at the IPV6 support page:
The current version of the firewall, VPN, terminal list, cloud service, etc., may not support IPv6 for the time being. Therefore, the IPv6 function can only be used for configuration within this interface.
IPv6 - GL.iNet Docs (
Looks like IPv6 has some compatibility issues with the Hardware Acceleration option too.

Just to confirm that is is an issue, could any of you try to enable both and see what happens?
Easy way to test is navigate to after the config is done and run a speed test.

This is very useful info. I am asking guys to have a check.