Brume 2 remote access for DDNS

Hi, may i know that are your Brume 2 DDNS remote access is working on properly?

Because I have toggles on the button for both http and https for remote access of the DDNS but unfortunately is not working?

DDNS is working on my Brume 2. You can try looking up the IP address of the domain name in a WIndows command prompt:

nslookup (domain name for your router)

Where are the toggles on the button that you are referring to?

I do not work for and I am not directly associated with GL.iNet

Yes, the ddns is working but I can’t remote access the ddns from outside even http and https is on?

I found the toggles right after I posted. I just tested accessing over https and it is working.

Can you try accessing with the IP address instead of the domain name? If the Brume 2 is behind a main router, then you have to set up port forwarding on that router.

Another issue that am found that my vpn server profile needs to regenerate after 2 or 3 days because no internet access after connected to the vpn server as well.

Because am generate the wireguard vpn file used ddns domain name instead my public ip

That’s why am suspicious for it?

Or maybe i have done something wrong because even access with my public ip still cannot.

Brume 2 is my main router.

I noticed that the WAN on the Brume 2 has randomized MAC addresses enabled by default. Your ISP may assign a different public IP address when the router’s MAC address changes.

I disabled randomized MAC addresses on my Brume 2 via Admin Panel → Network → MAC Clone → Your Router (WAN) (set MAC address to the hardware default).

Okay. Later i will check for it. Btw, thanks :blush:

After checking, the WAN mac address as set for factory default.

As you can seems that the DDNS is working but i can’t remote access the ddns from outside for http or https after the toggle is on.

Both ddns hostname and public ip cannot access as well.

Before that, flint is my main router which able to remote access the DDNS after the toggle button is on.

I have no more ideas actually what is going on? Or i have set up wrongly?

Maybe one of the factor causes my wireguard vpn server fail after generated 2 or 3 days, because no internet access as the public ip is keep on changes.

Each of 2 or 3 days, i need to re-generate the wireguard profile in order to used the vpn server again.

That what am suspicious for it.


My DDNS on the Slate AX has never worked when VPN is active (l use wireguard client) even when GL.iNET services are excluded from using VPN and it tells me that I don’t have a public IP address despite being 100% that I do. I finally gave up and will have to do with using goodcloud to remotely manage my router but appreciate that using DDNS in VPN server profile can prove to be a significant problem.

Me too, am also gave up and really don’t know what is going on?

As far as am concern that each of 2 or 3 days need to regenerate the wireguard profile in order to access the vpn server again, it’s really hassle.


The Brume 2 ought to be fast enough that you could use Tailscale to get around 100mbps, and it’s overlay would solve that problem for you.

(Really it will solve both of these problems for you. Does require some setup though)

I have found out the issue. During the vpn client is on even we have toggle on the Services from GL.iNet don’t Use VPN, the remote access of ddns is not working.

After disconnected the vpn client then only able to remote access of the ddns.

Hopefully, there is a fix on the next firmware.


1 Like

Are you running Firmware 4.1.1 on the Brume 2 router? When I enable Services from GL.iNet don’t Use VPN, I get the correct public IP address and, when I disable it, I get the VPN server IP address.

Yes, am using the latest 4.1.1.

No matter am enabled/disabled the Services from GL.inet don’t Use VPN, I’m still not able to remote access the DDNS, except the VPN client is disabled.

Which mean if am using vpn cascading then the remote access of ddns if failure.


It should be a bug. If you toggle this option one more time, change ddns not using vpn, the ddns should resolve to correct wan IP.

For whe you use vpn cascading, pls use IP, not ddns.

Noted. Hopefully, there be a fix on the next firmware upgrade.