Brume 2 - Show different subnet clients in gui

Hi. I have the Brume 2 and I've managed to create vlans and also setup the guest, my questions are as followed.

Is there a way I can manage / see the guest clients inside the glinet GUI that are on a different subnet.

For example I have my default Lan clients and they are all listed inside the Clients tab, I can then block, limit etc each client. I want the same functions for my VLAN guest I have created however they don't show up in the list.

I don't mean to bump this however Im going mad here. I've read countless posts, tried different things and still I can't get the different clients to show. I do however remember seeing a device with a different subnet in my list before I started messing again so I've no idea what I did or changed. I'm doing the edits via Luci gui

Any help would be appreciated.

What did you change? Maybe just post your settings as screenshots.

Hi thanks for replying. Well I've had a bit more luck since posting and persisting. What I did was create a VLAN(802.1q) ID under device and assigned it with "30" then I went to the interfaces and created the guest however I attached the eth1.30 vlan, that worked but it didn't show any client in the GUI. I then went back to devices and left the eth1.30 (VLAN30) but then I also created a "br-guest" bridge and assigned the eth1.30 vlan that I had created prior to the bridge that way.

I Went back to the interfaces tab and edited the Guest network from "Software VLAN: "eth1.30" to: Bridge "br-guest" (guest) which has my VLAN30 only inside and now anything connecting shows up. A guide I read wasn't saying anything about making a bridge but as soon as I made / changed it to a bridge they started showing the gui.

The guide I followed to add the guest back to the brume 2: Setting Up Guest WiFi with Unifi Access Points and GL.iNet Gateway: Need Guidance! - #9 by dengxinfa

I am not fully sure why a bridge shows the clients in the GUI but just a eth1.30 vlan by itself doesn't?

I am guessing the reason I can see the guest clients inside the GUI now is because there's some hard coded GUI code that references "br-guest" is that correct?

My next step is to replicate the br-guest but this time I want "br-iot" I did the exact same steps for this VLAN and it works in the background but for these clients they don't show in the GUI. Is there a way I can tell the GUI clients list to also populate for the "br-iot" or for any "br-" that I make in the future, if indeed I am doing things correctly.

I am doing all this on the brume 2 which is my main router in my network. Modem (bridge mode) > Brume 2 > managed switch > unifi access points for WiFi with vlan tags for Guest and IoT

As GL GUI have not support the VLAN, it could not show the VLAN's clients on GL GUI.
GL GUI can be identified the bridge(s) which is default and custom create. According to you describe as the above mentions, actually different bridge to form any groups for your different devices.

Hi Bruce, I'm not quite following you. You say that the GUI can show different bridges however I can't replicate this. It will show me the br-lan and br-guest but when I create any other bridge (br-iot) it doesn't show that in the glinet gui, is there somewhere that I need to reference my bridge name (br-iot) for it to show in the glinet gui?

I guess that the br- is hardcoded inside the GUI. So br-guest and br-lan work - but custom ones don't. The GL GUI is pretty static spoken of configuration.

That's exactly what I was thinking when I first posted, Bruce's comment suggest it could work for custom ones though. I found etc/config/gl-tertf which references br-lan and br-guest I added list local_network br-iot and rebooted but that didn't do anything. There must be a way I can edit the files, it's just knowing where to look.

Most GUI logic is inside compiled JS files in /var/www - no way to modify them.