Brume MV1000 - OpenWRT 21.02.03 back to gl.inet firmware

I bought a Brume 2 which is a nice device but only has two ports, I also just bought a used original Brume MV1000 as sometimes having 3 is helpful without carrying around an extra switch. Now I received it though it has OpenWRT 21.02.03 on it, I’d prefer to go back to the gl.inet firmware.

I tried opening up uboot but just get a message that UPDATE FAILED - Something went wrong during the update… You can also get more information during update in U-Boot console. Device boots up into OpenWRT 21.02.03 no problem but I guess when original owner installed OpenWRT 21.02.03 it messed up uboot?

If I use flash new firmware option in OpenWRT I get message of: Image check failed
upgrade: device glinet,gl-mv1000 not supported by this image
upgrade: supported devices: gl-mv1000-emmc
upgrade: reading partition table from bootdisk
upgrade: extract boot sector from the image
upgrade: reading partition table from the image
upgrade: partition layout has changed. Full image will be written. Image check failed.

I could use force overwrite but don’t want it to get confused and try to shove the 40+ MB image into the 16MB NOR flash or anything silly like that and end up with something unbootable, am I overthinking this and it’s fine to just force overwrite this image with flash new firmware option in OpenWRT? I’m guessing image check failed is just due to Ath79 vs AR71xx change between OpenWRT 21.02.03 and Gl.inet 3.215 based upon 19.07 but no idea if safe to proceed with this as a force overwrite…

If not then how do I go about getting this device back to gl.inet firmware?

Ps I’ve never needed to ssh into router etc so if that’s where we’re headed please explain step by step literally to the point of click this, type this etc level of detail - I’d rather get ultra simplistic steps where I can’t possibly make a mistake. More basic the better, please treat me like a simpleton and it can’t possibly go wrong :laughing:


To confirm a few things, you can currently access the uboot web interface, right?

No the issue was that I couldn’t access uboot, at or would just get message of “UPDATE FAILED - Something went wrong during the update… You can also get more information during update in U-Boot console.” Not sure why since I hadn’t done any updates, certainly none for uboot, I guess previous owner must have but device had been power cycled a few times as well since I received it.

Just turned it on again to try and get a screenshot of the UPDATE FAILED uboot screen where it was stuck and bizarrely this time uboot loaded up fine, just fed it the image file for 3.215 and has flashed OK so back to working gl.inet firmware now. Have no idea what was going on with uboot yesterday but at least it is now working. I guess next time if it does something odd like this I’ll leave it powered off for a day and retry although it took 4-5 days to arrive in the post so you’d think that would have been long enough for it to start behaving.

Anyway, issue solved and the secret to uboot is perseverance :slight_smile:

Thanks for getting back to me though.

1 Like

What was the Uboot Version?
The Uboot version might have been old and it finally updated, usually you need to do that manually.

Not sure, don’t remember seeing any version shown on screen but I’ll try and have a look when home again, I did notice it only had one upload button though which would indicate it’s not one of the really early versions where there were two (although not sure if original Brume ever had uboot that old? Only remember seeing old version with two upload buttons on one of my AR300M’s).

I guess it’s not impossible previous owner tried to update uboot immediately before they posted it to me but no idea why they would have done that or how it eventually completed a day after I received it when I hadn’t tried any uboot update myself…


Bottom of doc tab showing how to update Uboot

When you were flashing .img it was not The is to update uboot.

Uboot Version number is kind of small at the bottom of the the page.

OK I’ll have a reread of the doc and see what uboot I have/update if old when I get back although now I have the latest gl.inet firmware I wanted installed it doesn’t really matter as much. Both and were giving a message of “UPDATE FAILED - Something went wrong during the update… You can also get more information during update in U-Boot console.” when it was having issues. As soon as I could actually use uboot process was nice and easy to load 3.215


Did you try uboot on another pc?

Some network card has problems.

Hi, I’ve only used uboot 3/4 times (different device each time) in 6/7 years but every time has been with the same laptop and I managed to eventually flash it back to gl.inet firmware using the same laptop so not a computer issue. Wish I’d taken a photo of the uboot “UPDATE FAILED" screen it was stuck on but I’m sure you know the one I mean anyway. Like I said is fixed now and the brume eventually resolved things with uboot by itself, not sure how or why but I never plan to load anything but the gl.inet firmware on this one so should never need uboot again unless something goes wrong with a future firmware update via gl.inet interface which seems unlikely. thanks

1 Like

For those who run into this in the future:

The solution is to go into incognito mode and try again. If you look at the URL carefully, you’ll note that it points to luci, not to the firmware page.

1 Like

Hi, interesting although whilst that message looks about right I thought the text was a little different… maybe not as I don’t have a photo to be sure.

As for incognito mode I didn’t try that but did try accessing from firefox, chrome and even Edge which I never use, all were giving the same update failed screen so not sure why incognito mode would have helped if the other browsers had never attempted to connect to this device before. Also the web addresses used for each was and - it definitely had not changed these in address bar to anything luci (unless you’re saying the github link would have pointed to openwrt and update failed message was therefore luci related even though showing on uboot screen? I didn’t try but that would have been unexpected since message mentioned to ‘get more information during update in U-Boot console’, would have expected github link to go to a gl.inet page).

As I said issue solved now but all things I can keep in mind if I ever buy another used brume and get this again.