[bug] MT1300 missing nslookup and hostip

After installing OpenWrt image, and then reverting to original firmware, the original web-interface is not present (just luci).

After installing bind-host this issue got resolved and everything appeared.

This error message appeared after install ddns.

BusyBox's nslookup and hostip do not support to specify to use TCP instead of default UDP when requesting DNS server!
- You should install 'bind-host' or 'knot-host' or 'drill' package for DNS requests.

I would install GL.iNet firmware by Uboot or install a openwrt version that is known to work. If you want to continue to use Openwrt you might try posting on their forum board

:gl_emoji_dizzy:I do not work for and I am not directly associated with GL.iNet :gl_emoji_shacking:

1 Like

Maybe just browser cache problem.

Just so you know, the only thing that solved the issue was installing bind-host, so it appears that it is a dns issue.

You can reproduce this by installing one of the original firmware images, after installing vanilla openwrt.

I didn’t try. But I don’t believe it is the issue, unless you kept settings etc.