Bug on B1300 with pre-release firmware 3.100

I had tested to update the firmware of B1300 to v3.100 and found that the HTTPS remote access from Wan Side not working.

The setting on GL user interface showing the https remote access had been turned on and the firewall setting on LUCI showing the 443 port had been turned on, too.

However, I had tested by using port scanning software showing that 443 port had closed.

I had tried to reset the router to default still not working.

I flashed it back to 3.027 and it work and the 443 port had opened.

Please help to check.



Hi Jack,
Sorry about that.
The openssl.conf configuration was overwritten by the original file.
We will update the firmware as soon as possible to fix this problem.
You can also manually modify the configuration to support it currently. Thanks.
~# cat /etc/lighttpd/conf.d/30-openssl.conf
server.modules += ( “mod_openssl” )

$SERVER[“socket”] == “” {
ssl.engine = “enable”
ssl.pemfile = “/etc/lighttpd/server.pem”

After I follow your instruction to change the config file and reboot the router, I cannot login on both http and https by Wan and Lan side.

I can only login by ssh and I got this error when I try to restart lighttpd

root@GL-B1300:~# /etc/init.d/lighttpd restart
2020-02-18 18:15:53: (configfile.c.1128) source: cat /etc/lighttpd/conf.d/*.conf line: 237 pos: 1 parser failed somehow near here: (EOL)
2020-02-18 18:15:53: (configfile.c.1128) source: /etc/lighttpd/lighttpd.conf line: 68 pos: 1 parser failed somehow near here: (EOL)

Oh, sorry, my mistake. It missing parentheses when I copy.

$SERVER["socket"] == "" {
        ssl.engine                 = "enable"
        ssl.pemfile                = "/etc/lighttpd/server.pem"
1 Like

Thank you so much!! It work!!