Bug + Security Issue: Special Characters Remote SSID Name

Hi @alzhao,
I think i found a bug today.
I was trying to connect to a McDonalds free wifi, the name was like so: “McDonald’s Free Wifi”.
It showed up in the list correctly, with the single quote after the d, but after adding the connection, in the saved stations page it showed up only as “McDonald”.

The wisp connection also failed since it was not able to find that station since it was cropped.
I guess one of the scripts needs to be guarded for special characters in the SSID name?

Yes and it is also a potential security issue, a small but crafty ssid name could cause things to happen on the router, shown in a later post.

Made a local test connection with the same character, same result, it doesn’t work :smiley:

Just for fun a made a more broken one called:


As expected it breaks even the list:


It means that all handling of the SSID name’s should take into account special characters that can break the parsing in bash scripts.

This is also a security issue because a well crafted SSID name could potentially crash or do funny things on the router, as you can see in the last screenshot, where is “data” coming from?

@alzhao could you take a look at this? i hope i can be fixed in the next update, or in v3

Seems this is a problem. Not sure if this is serious bug. But definitely need to fix the UI.


Thanks @alzhao @kyson-lok

OK, we will check this.

@kyson-lok Will this be fixed for v3? :slight_smile:

Yes, v3 has fixed it.

It can be, it should be configured allway UTF8 by programmer. Same by gli admin and advanced admin password.