Building the OpenWRT image

I’ve been trying to work around my issues compiling kernel modules by building the openwrt image since that will allow me to make sure the kernel/modules match perfectly, but this hasn’t been going very well. It’s easy to configure and build the image but I can’t find any resources that would indicate the exact configuration options used to build the “official” Domino Pi image, just the instructions linked to below:

The .config files that exist after cloning the git repo and selecting the Domino Pi configuration option don’t match up with the v1.1 binary image that’s being distributed (At, so I am stuck without those files. The image I built is only 2.9M and is missing many of the critical files/utilities that ship with the 8.9M Domino Pi image, making it unusable.

If I could get a copy of the .config files for openwrt top-level and the kernel it would be incredibly helpful The paths to the .config files I need are below:



Hi Larry, you need to download this package domino-firmware/domino-pi/domino-pi at master · domino-team/domino-firmware · GitHub, put this in your openwrt/packages/domino-pi

You also need to download these files domino-firmware/domino-pi/root-files at master · domino-team/domino-firmware · GitHub and put them in your openwrt/files/

Then, you can do a rm openwrt/tmp/* -fr to clear your tmp files, do a make menuconfig again.

You will find a package called Domino Pi. Just select Domino as target and Domino Pi package, then everything will be selected automatically.

Do a make now!

I’m not sure which directories you’re referring to, can you give me the entire path of the destination directories? You said to copy the files from domino-firmware/domino-pi/domino-pi at master · domino-team/domino-firmware · GitHub to <openwrt root>/packages/ but there is no “packages” directory at that location. Here are the “packages” folders I found:


Maybe you meant “package” instead of “packages”?

The next step for copying the data from domino-firmware/domino-pi/root-files at master · domino-team/domino-firmware · GitHub to “files” is confusing since there is no directory called “files” at the top of the openwrt tree, although there are many deeper in the tree-- which “files” directory did you mean? Am I supposed to create a directory called “files” at the openwrt top level and copy the contents of domino-firmware/domino-pi/root-files at master · domino-team/domino-firmware · GitHub to it?

If you could clarify what I should copy I would appreciate it.


Sorry, it is “package”

and you need to create the “files” dir.

Hi, thanks for clearing that up. Unfortunately I’m having problems with getting any USB device to be recognized aside from the SD card on the 3-port USB/SD card tile. I followed these instructions when building, which help clarify what you meant in your messages:

The image is properly built and works fine except that it won’t recognize any USB devices that are plugged into it. The 3-port USB/SD card tile doesn’t provide power to what’s plugged in and never recognizes anything. No errors, no messages from the console, etc. I can boot from the image I created and have USB not work, then boot from the stock image and have USB working without changing whatever is plugged in, so it’s definitely not a hardware issue (I also tried other Domino devices with the same result). It seems to be specific to the 3-port USB/SD tile since the tile itself and the SD slot is recognized (From lsusb output), it’s just that anything plugged into the USB ports doesn’t get powered up or recognized.

Any suggestions? Are there kernel patches that I might be missing? I tried to follow the instructions exactly and don’t have any issues seeing the Domino target or the domino package selections from the OpenWRT config menu, it just seems to be an issue with the kernel.

Are you supplying an External +5Volts on the Board Bus, or only +3.3V, or higher than 5V to the Board ?
The Board may not Need +5V source - but the USB Port does need it …

I am using the Pi with 5v from the USB cable plugged into the Pi board’s micro USB connector. I am using the Pi with a 3 port USB/SD tile plugged into it. This works fine with the stock 1.1 firmware but if I use u-boot to flash or boot from a different kernel or image it no longer recognizes and powers anything plugged into one of the 3 USB ports.

The problem is most likely to be a gpio control on usb power. GPIO6 need to be high so that USB board has power.

We are not sure the reason it is low in your firmware, as we didn’t have some special code for this. We will check the reasons. For now, you can manually set voip to high.

That did it! Setting GPIO 6 to on state immediately turned on power and allowed the Domino to see attached devices. Thanks for the help!