Can Flint use SQM?

I’ve received my order, and the router is working well.

However, I have failed to install luci-app-sqm via LuCI and it shows a kmod is missing.

Has anyone successfully installed SQM? Can you share your method and experience?

Thanks

Thanks for clarifying that.

Does Flint also not support fq_codel or any other methods to control bufferbloat?

I’m don’t know yet, need ask @alzhao

fq_codel is supported. Its sqm-scripts is older version. To support cake, need to port code to tc/iproute2 and port kmod-sched-cake, and maybe more. Now kmod-sched-cake is ready. Other work is schedule later time.

Soft repo had some dependency issue for sqm-scripts, now it’s fixed. You can use sqm-scripts and luci-app-sqm (both version 1.0.7), maybe check if that mitigate bufferbloat.

I’ve successfully installed sqm and configured Luci-app-sqm

I’ve set up:

  1. interface name to eth0 (wan)
  2. ingress to 80000
  3. egress to 80000
  4. link layer to 124 (80 for Wireguard ipv6 and 44 for ethernet)
  5. enabled SQM
    And left everything else on default

Upon some testing, the ingress doesn’t seem to be affected by the settings and the egress setting works to reduce bufferbloat.

Thanks for pointing out link layer setting(124). I also found that NAT short cut driver should be turn off to make qos work.By command:

/etc/init.d/qca-nss-ecm stop

If only egress works, then you can try add another raw of settings on interface br-lan, which is downstream facing while eth0 is upstream facing.

3 Likes

Thanks, that worked for me perfectly after the command and br-lan settings

I’ll share with others my settings:

1st set of SQM:
Enable this SQM instance: tick
Interface name: br-lan
Download speed: 0
Upload speed: 70000

2nd set of SQM:
Enable this SQM instance: tick
Interface name: eth0
Download speed: 0
Upload speed: 70000

Anything above 70000 seems to have bufferbloat while running IPV6 Wireguard and nothing else heavy

2 Likes

Unfortunately, I have the problem that no matter what I adjust, nothing changes in the connection.
Both bufferbloat and QoS remain the same. When I do a speed test, the ping jumps directly from 10ms to 100ms.

How do I get QoS to work properly?

Can you share your SQM configuration?

Sorry for the late reply, but I was only able to take care of the router today.

So after the command as described above, everything works now.
/etc/init.d/qca-nss-ecm stop

What is the driver actually for that I switched off with the command?

I have a question, after the last update I noticed that with the command " /etc/init.d/qca-nss-ecm stop " the bufferbloat is only reduced during the upload, but during the download it still remains high…

is there now another command that can reduce the bufferbloat on the download?

Please try add another raw of settings on interface br-lan to see if it works.
Could you share which site do you use to test bufferbloat?

I have now reinstalled and adjusted the SQM software. + " /etc/init.d/qca-nss-ecm stop " executed. Now I don’t have a bufferbloat anymore, but now I can’t change the setting for “Download speed (kbit/s)”. no matter what value I set here, I have a download speed of max 27 mbit/s (my line is 250mbit/s).

The values for the upload speed are adopted normally.

What could be the problem?

I always use dslreports.com or Bufferbloat and Internet Speed Test - Waveform for testing.

What I also noticed is that I can activate the SQM when I “Enable this SQM instance”, but when I remove it, it does not deactivate it until I restart the router.

My Conf:

config queue
option debug_logging ‘0’
option verbosity ‘5’
option qdisc ‘fq_codel’
option qdisc_advanced ‘0’
option linklayer ‘ethernet’
option upload ‘30000’
option script ‘nxt_routed_hfsc.qos’
option enabled ‘1’
option download ‘180000’
option interface ‘eth0.7’
option overhead ‘124’

ifstatus wan | grep device
“l3_device”: “pppoe-wan”,
“device”: “eth0.7”,

If you add setings for eth0.7 and br-lan, the download speed is controlled by setting values of br-lan.

This may be a luci bug, you can try to unclick enable and apply, not remove it directly.

Hi, I just stumbled into this thread and as someone pointed out, the egress works, but the ingress doesn’t. At least for me it doesn’t matter if I’m using br-lan or eth0 the problem is the same, there’s no limit on the bandwidth.

Also, turning the debut logs on the interface shows this:

egress shaping deactivated
/usr/sbin/tc qdisc del dev br-lan root
RTNETLINK answers: No such file or directory
/usr/sbin/ip link add name TMP_IFB_4_SQM type ifb
/usr/sbin/tc qdisc replace dev TMP_IFB_4_SQM ingress
RTNETLINK answers: No such file or directory
QDISC ingress is NOT useable.
/usr/sbin/ip link set dev TMP_IFB_4_SQM down
/usr/sbin/ip link delete TMP_IFB_4_SQM type ifb

This is my current configuration:

config queue 'eth1'
	option qdisc 'fq_codel'
	option script 'simple.qos'
	option qdisc_advanced '0'
	option enabled '1'
	option interface 'eth0'
	option linklayer 'ethernet'
	option overhead '44'
	option upload '20000'
	option debug_logging '1'
	option verbosity '8'
	option download '0'

config queue
	option qdisc 'fq_codel'
	option script 'simple.qos'
	option linklayer 'none'
	option enabled '1'
	option interface 'br-lan'
	option download '50000'
	option upload '0'
	option debug_logging '1'
	option verbosity '8'
	option qdisc_advanced '0'

Try to change br-lan’s linklayer to ethernet like interface eth0
and set value upload bigger than 0 for ingress I guess.

Linklayer doesn’t matter in this case. The upload parameter doesn’t do anything else besides limiting the bandwidth on the upload and even if I set it doesn’t change the ingress issue.
The error I posted seems to be part of a command that fails to load a module.

I think SQM is just broken from the get go, I have the same configuration in my R7800 and it’s working without issues. TBH I think I’ll just need to wait until this is fully supported by OpenWrt in order to use it, or see if subsequent updates fix the problem. Hopefully GL.iNet can give an ETA on when that would happen.

Hi, here is my test config:


config queue 'eth0'
        option upload '10000'
        option qdisc 'fq_codel'
        option script 'simple.qos'
        option qdisc_advanced '0'
        option linklayer 'none'
        option enabled '1'
        option interface 'eth0'
        option download '0'
        option debug_logging '1'
        option verbosity '8'

config queue
        option qdisc 'fq_codel'
        option script 'simple.qos'
        option linklayer 'none'
        option enabled '1'
        option interface 'br-lan'
        option download '0'
        option upload '20000'
        option debug_logging '1'
        option verbosity '8'
        option qdisc_advanced '0'

This make download limited to 20000 and upload limited to 10000. Need to turn off NAT acceleration by command:

/etc/init.d/qca-nss-ecm stop
/etc/init.d/qca-nss-ecm disable

Yes, only egress work, adding queue at br-lan is a workarond for ingress limitation for eth0(wan).
Maybe 4.0 firmware(in develop) will support ingress qdisc.

1 Like