Can I revert or install firmware with the GL.iNet ui?

I have an AR750S EXT and I installed the OpenWrt firmware but I dont like the UI, is there a way to revert the firmware or install the latest GL.iNet firmware?

Using Mac OS X I’ve tried the debrick process to reinstall the GL firmware: Debrick via Uboot - GL.iNet Docs
I see the lights flash 5 times, then release the reset button, I’ve changed my IP address to but I am unable to access the UI at

Please help,

The instructions are a bit vague in terms of when you’re in uboot mode. Please ignore the number of seconds to hold the reset button down. When the left and middle leds are solid you will be in uboot mode and you can release the reset button.

I do see the power and 2G lights are solid and then release the reset button, but when I set my Mac IP address to and try to access, there is no web access for uboot. The browser just hangs.

I have the ethernet plugged into the WAN port on the router

Before I tried macbook and uboot works. Pls watch the video and follow it carefully. Most important point:

  1. Only connect one cable from macbook to the router
  2. Connect the cable before powering the router
  3. Pls make sure your browser is not redirected to https. Only use http
  4. Turn off any vpn or proxy in your system if you have

If you tried everything but still does not work, need to change to another pc.

Thanks for the info.

I tried:

  • A different Mac
  • A different network cable
  • A different power cable to the router
  • A different power source for the router

Both computers:

  1. Using 1 cable directly connected from 1 Mac to the router WAN port
  2. Plug the power into the router with reset pressed
  3. Wait for 5G blinking light to stop, and solid 2G light with solid power light
  4. Release reset button
  5. Change network setting from Configure IPv4 Off to Manually
  6. Set IP address:
  7. Set Subnet Mask:
  8. Click apply network settings
  9. Verify computer has IP address
  10. Check Computer network status: Connected - Ethernet is active and has IP address
  11. Verify no proxy on computer
  12. Verify no VPN on for computer
  13. Attempt to access
  14. Browser hangs and responds with “This site can’t be reached took too long to respond.”
  15. Try ping “Host is down”

Repeat steps above but change:

  1. Using 1 cable directly connected from 1 Mac to the router LAN port
    Same result

Repeat steps above but change:

  1. Using 1 cable directly connected from 1 Mac to the router LAN port
  2. Change network setting from Manually to DHCP
  3. Verify Computer has IP address from DHCP
  4. OpenWRT Login page is displayed

Has uboot been removed or corrupted after OpenWRT firmware installed?

Can I install GL.iNet web interface on top of OpenWRT or am I out of luck going back to that Web UI on the device?


One more thing to try: add as gateway.

Can you let me know which OpenWrt firmware did you download? send me the link

You can flash in current openwrt firmware. Do not reserve settings.

I tried adding as the router gateway but it didn’t help.

The current OpenWRT version is:
[Powered by LuCI openwrt-18.06 branch (git-18.196.56128-9112198)](http s:// / OpenWrt 18.06.0-rc1 r7090-d2aa3a1b62

I don’t have the link to the source, but I thought it was the clean version here:

However, when I try to flash either one of those images using the OpenWRT I am getting the error:
“The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.”

And I am unable to find any image anywhere that will load without the same error message above.

So you flashed the “clean” firmware from our website?

Can you do this:

First ssh to the router and use this command to check the flash status. I want to know if it is nand firmware or nor.


Download the the new firmware, e.g. the .tar in GL.iNet download center

Then upload to the router using winscp, put the file in /tmp
Then update the firmware by force

sysupgrade -n -F /tmp/openwrt-ar750s-3.211-1126.tar

If still does not work. The only way is to make uboot work. I never met a case that uboot does not work on AR750s.

Thank you for this, the firmware update worked.

Here is the output from mount and df:
root@OpenWrt:~# mount
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/ubi0_1 on /overlay type ubifs (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)

root@OpenWrt:~# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 2816 2816 0 100% /rom
tmpfs 62304 576 61728 1% /tmp
/dev/ubi0_1 110096 6580 98680 6% /overlay
overlayfs:/overlay 110096 6580 98680 6% /
tmpfs 512 0 512 0% /dev

I also tried the uboot process again after the firmware update but still unable to connect using a Mac. But its fine now because the firmware update worked. I want to test the uboot process with a windows computer but unfortunately I dont have access to one right now.

Thanks again

1 Like