Can not connect to the router from local network

Hi there,
I can not reach my Slate Plus from within my network. The IP address that is attributed is not reachable from the local network. The router is working, I have another device connected to it, even vpn is working but there is no other way except to connect with wifi to access to the router. On my network it appears as 192.168.1.120. And when connected to the router, access is at 192.168.8.1.
What can I do to access to the router? I already factory reseted it, installed the latest firmware.
Thank you

I can see device from local network at 192.168.1.120 but can not connect, page not loading
Device is connected on wan and gives internet to another devices successfully via lan port
Once connected to the device with wifi, he appears at 192.168.8.1

Try to enable HTTPs access:

System > Security > HTTPS Remote Access

Tried this, doesn’t change, still impossible to access the modem.
Note : I do not use a vpn and tried with different devices

So http://192.168.1.120 does not work now?

I tried http didn’t work and now I tried https://192.168.1.120 and it does work. It shows a page where certificate is not secure, I continue and the login page appears, I am able to login!

is there a way to access to devices that are connected to the Slate Plus from the local network?
It seems currently the modem blocks the access to the devices.