Can not connect with 4G on GL-X300B-GPS


yesterday my GL-X300B-GPS arrived from amazon.
Unfortunately it does not connect with 4G. I got following message

SIM card cannot be registered. Please check: 1. You are using the compatible modem for your carrier; 2. Whether a specific APN or data plan is required.

I ve tried two SIM cards from Vodafone, PIN is not needed. Both SIM card are working in my mobile phone
I ve connected both 4G antennas

Firmware: 3.215
AT Commands:


+CSQ: 18,99


+COPS: 0


+COPS: (1,“Vodafone . de”,“Vodafone”,“26202”,7),(1,“o2 - de”,“o2 - de”,“26203”,7),(1,“Telekom
. de”,“TDG”,“26201”,7),(0-4),(0-2)

i have addad a space before an after the dot. I am not allowed to post more than two urls




+QNWINFO: “FDD LTE”,“26201”,“LTE BAND 20”,6400

I can send every AT command on Port /dev/ttyUSB3 and /dev/ttyUSB2

this are my settings

I ve reseted the modem
and I ve also done a factory reset

The modem is a EG25G


I ve also a GL-XE300
this ist working as expected, with the sam SIM card.


+CSQ: 17,99


+COPS: 0,0,“”,7




+QNWINFO: “FDD LTE”,“26202”,“LTE BAND 20”,6300

Maybe someone as an idea where the problem is located


You could try mac cloning. It’s possible your provider blocks modems. You can easily do this in the GL panel, under network/mac address. There choose “clone” & select your current mobile phone

thanks for your advice, but unfortunately it does not work ;(
any other ideas?

I restarted the device, and I also tried to reset the modem

I ve bought a second one, same issues.

Is here some advice or should i send them back and use an other vendor?

1 Like

@alzhao or @luochongjun might be able to help.

@lizh can you have a check?

Please help execute the AT instruction:


here are the commands

+CREG: 0,2



maybe this is usefull

OK no solutions found, no more answers. I will send the devices back and have a look for an other one

I am sorry to hear that.
As XE300 can work, X300B should also work with the same SIM. If you still have the device, can I do a remote check?

I am very sorry that for some reason, this information was put into the dustbin, so did not reply in time.

Please help check the following situations:
1,Check to see if the antenna is OK?
2,Check if APN is correct?

+CGDCONT: 1,“IP”,“”,“”,0,0,0,0
+CGDCONT: 2,“IPV4V6”,“ims”,“”,0,0,0,0
+CGDCONT: 3,“IPV4V6”,“”,“”,0,0,0,1
+CGDCONT: 4,“IPV4V6”,“VSBLAPP”,“”,0,0,0,0

Antenna is connected and looks good

If you still have the device, can I do a remote check?
yes I didnt send it back until now. I ve unpack it again

you can perform remote checks

APN doesn’t seem to be right.

My cloud platform account is ‘zhangli’, you can share the device with me.

ok I think I ve shaed the device with you
right now I have a things mobile sim card inserted.
the things mobile is not workint with the other one too.
But it is working with my mobilephone an it is also working with an other IOT Router

I ve tried the apn “pepper” and “TM”

Hi shab256:
I didn’t see your device on the cloud platform. Are you sure you shared it?

This is what i see

I am having the same issue with my unit. Were you able to get it working?

I have same similar problem with GL-XE300, were you assisted?

Can you assist remotely?

You can share with ‘gl.inet_support’.