Can’t connect, Beryl AX router

We’re at a campground and are trying to connect to the wireless signal. It’s not a captive portal. I can connect on my iPad but not using the router. When I connect, I get a BSSID but no IP address. I tried MAC clone but no success. I thought about using the IP address I get on my iPad but I can’t find where I can manually enter the WAN IP.

Suggestions on either setting IP manually or how to get the IP from the upstream router?


1 Like

To manually set a static IP on the Beryl AX WWAN:


I do not work for and I am not directly associated with GL.iNet

1 Like

Ok, got it. I didn’t notice the ability to manually set the IP when initially connecting to the network. I also hadn’t thought to go into the LuCI interface. It’s now working, after cloning the MAC and the IP address from the iPad.

Question: I used LuCI to set the IP. When I go to another location to access a different network, will I need to reset the IP to Automatic or will the new network automatically use Default?


I have not personally tried it, so I do not know whether the static IP stays for a different network. You can confirm the next time you connect to a different network.

Ok. I’ll be able to check in about a week. Thanks.

I am pretty sure that you will need to reset but I have to admit that I have not tried it either.

No, it looks like changing the IP address is for that connection only. We are now at a new site and it shows that I am using the DHCP client. All I had to do, besides connecting, is to change the MAC to Automatic.

Thanks for your help on this.