Can‘t use my AppleTV with my GL-AX1800 (Flint)

Hello there,

I use the GL-AX1800 Router with a VPN connection. I wanted to connect my AppleTV via LAN to the Router but I‘ve got no connection. I even try to use the vpn privacy to deactivate the vpn for the AppleTV but it don‘t even work with that.
I use Custom DNS Server ( and
Did I miss something? Please help me.


Are you trying to have Apple TV go through VPN or go through normal Internet? Does the router show that VPN is successful with “IP Address” and “Data Received / Sent” displayed?

Does the router work with a computer and/or other devices through LAN?

Did you mean “vpn policy”, not “vpn privacy” … better to leave it off for now when troubleshooting.

1 Like


The AppleTV go through with VPN. The VPN works fine on the Router. All other Devices that are connected to the router works. Only the AppleTV didn’t work.
Yes I mean VPN policy :sweat_smile:
I want to connect the AppleTV with the GL-AX Router to control it with my iPhone.

Items to check:

Apple TV networking should be set to DHCP.

Apple TV should have IP address in same subnet as the router and default gateway should be set to the router IP address. Subnet mask should be

Test network connection from within the Apple TV interface.

Turn off VPN on the router and check if Apple TV can connect to Internet


I’m sure it’s a config issue. I have an Apple TV 4K connected through VPN on the AX1800 without issue. @wcs2228 makes some good suggestions on troubleshooting, but wanted to let you know it was possible. ;-p

1 Like


Ok this is crazy.
I tried setting the AppleTV last night and nothing worked. Then I undid all the settings I made on the AppleTV last night. When I just tried again everything seems to be working with no problems.
All settings on the router, as well as the AppleTV are unchanged and somehow it still works.

But thank you very much for your help :smiling_face_with_three_hearts:

1 Like

Apple device is just strange.

Not sure if this is related. But when you connect your iPhone to the router, iPhone may display a privacy warining, saying that the wifi does not support encrypted DNS. One fix is to forget the wifi network and reconnect. So no idea about the logic.