Cannot access to the clients over WDS

I configured my GL-iNet as a WDS client that repeats the wifi to the wired clients through it.

From the wired clients connected to the GL-iNet (laptop3 and laptop4), all the devices (laptop1-4, the upstream router, and the br-lan interface on the GL-iNet) are visible and responding to the ping.
Also, from the laptop1, all the devices are accessible.

However, from laptop2 (it can be arbitrary devices other than the devices connected to the GL-iNet), laptop3 and laptop4 are occasionally not accessible.
During the disconnection, I can still access, for example, laptop3 via laptop1, and when I run the ping to laptop2 from laptop3, the connection between laptop2 and laptop3 is recovered. (But after some time, it will be disconnected again)

Am I missing something on the configuration? Or is it due to a bag on the GL-iNet router?
Any comments are welcome!

I confirmed the issue on:

  • GL-AXT1800
  • OpenWrt 21.02-SNAPSHOT r16399+159-c67509efd7
  • Kernel version: 4.4.60

I configured locating the following script at /etc/uci-defaults/99-init

# Disable unused service
/etc/init.d/repeater disable
/etc/init.d/samba4 disable
/etc/init.d/relayd disable
/etc/init.d/tailscale disable
/etc/init.d/zerotier disable
/etc/init.d/parental_control disable

# Configure router settings

# Set hostname
uci set system.@system[0].hostname='router'

# Disable DHCP on the 'lan' network
uci set dhcp.lan.ignore='1'

# Enable DNS forwarding
uci set dhcp.@dnsmasq[0].server='192.168.8.1'

# Setup br-lan interface
uci set network.lan.proto='static'
uci set network.lan.ipaddr='192.168.8.10'
uci set network.lan.netmask='255.255.252.0'
uci set network.lan.gateway='192.168.8.1'
uci set network.lan.stp='1'
uci delete network.lan.dns
uci add_list network.lan.dns='192.168.8.1'
uci set network.@device[0].ports='eth0 eth1 eth2'

# Disable unused interfaces
uci delete network.wan
uci delete network.wan6
uci delete network.wwan
uci delete network.wwan6

# Configure 5GHz
uci set wireless.radio0.htmode='HE80'
uci set wireless.radio0.channels='36'
uci set wireless.radio0.channel='36'

uci set wireless.default_radio0.device='radio0'
uci set wireless.default_radio0.network='lan'
uci set wireless.default_radio0.mode='sta'
uci set wireless.default_radio0.ssid='WIFI_SSID'
uci set wireless.default_radio0.encryption='psk2'
uci set wireless.default_radio0.wds='1'
uci set wireless.default_radio0.isolate='0'
uci set wireless.default_radio0.ifname='wlan1'
uci set wireless.default_radio0.key='password'
uci set wireless.default_radio0.channel='36'
uci set wireless.default_radio0.ieee80211k='1'
uci set wireless.default_radio0.ieee80211r='1'

# Disable unused profiles
uci set wireless.default_radio1.disabled='1'
uci delete wireless.guest5g
uci delete wireless.guest2g

# Apply settings
uci commit

# Deferred reboot
( sleep 10; reboot )&

Do you use DFS channels for Wi-Fi?

I use a non-DFS channel only (36ch in the US), and while the connection between laptop2 and laptop3 is not available, laptop1 - laptop3 is still working fine, so it isn’t related to the wireless connectivity.