Cannot connect to hotel network

I’ve been traveling with the AX Slate this week have have been in three different hotels so far. I’m now in a Holiday Inn and cannot get to the captive portal page, despite all my normal tricks.

DNS Rebind is off, as well as any custom DNS. I’ve tried connecting successful on both my phone and laptop then cloned the mac address. Still can’t get the router to connect with a cloned mac.

I pulled up the laptop browser history and tried connecting directly to the captive portal page and that just timed out.

Any other thoughts on how to get this working?

1 Like

Hmm, I haven’t tested this or worked with captive portals before but I do have played around with different protocols.

but I need to understand what your encryption is, WPA2-EAP or WPA3-EAP?, Or is it not EAP at all?

What happens if you connect towards the AP you are still able to ping that gateway on their side or also timed out?

Often when you authenticate with a EAP protocol it should load a webpage inside the wifi manager on phones, but perhaps they don’t use EAP but a transparant proxy which hijacks ?, Perhaps you need to allow input from this gateway on wan only.

Often when there is a time out it means the firewall drops the connection, I believe inside the firewall zones you can see INPUT Drop on the wan zone, though it doesn’t seem a good idea to allow full wan for input.

It could also be a ip conflict, or rebind protection is still on hence its turned off, I noticed a few times in luci it was still on for me.

1 Like

Try disabling it via LuCi; I did a few days ago and I’m on a CP hotel WiFi network and had forgotten about the GUI issue, as I’d logged in without problems. Dig around for DNS

DNS Rebind is off in luci. No custom DNS is being used either. No EAP at all, it’s an open network to the hotel WiFi (which is why I need my VPN on the slate ax!).

A ping to the gateway times out. It does look like there is a highjack because the gateway is and on a phone or computer you get to a page hosted by

I’m luci I’ve tried disabling things like “domain required” and “authoritative” in the DNS setting but still can’t get the captive portal through the router.

Confirmed it’s off in luci.

1 Like

hmm have you tried to use the mac clone way by cloning the mac address of your phone? (also please confirm if the cloning is actually really applied since its beta :stuck_out_tongue: )

it sounds like they are able to block you based on the hostname or mac address, it could also be that you need to use their dns servers aswell…

Yes, I’m using their dns servers (they are the same as the gateway). I tried cloning both the computer and phone mac address. Still does not work.

This one is a challenge! Thankfully I’m only here one night.

Ok, now you have me wondering. I’m not entirely sure it’s cloning my mac address.

When I go in to luci under Network/Interfaces both LAN and wwan show my router mac and not the laptop I cloned.

How does one manually clone a mac in luci?

Can someone else verify if clone works?


I believe in luci you have to edit the wwan device, if you go to interfaces>devices>wwan there you should be able to see the mac address.

I have rc1 firmware here Dropbox - openwrt-ipq807x-glinet_axt1800-rc1.tar - Simplify your life

It fixed the dns rebinding problem. I also verified mac clone and it works on repeater.

Can you try?

I’ve tried the firmware and not DNS Rebind and Mac clone work. Unfortunately, I still cannot get to the hotel captive portal page.

I’m at a different hotel tonight and I’ll test everything there as well.

If someone is going to stay at a Holiday Inn in the United States, see if you can connect to the captive portal. I was not able to!

@alzhao A follow up on this. I was never able to make the captive portal page work at the Holiday Inn. I tried on the standard Beta firmware as well as the one you posted.

The next night I was in a Hampton Inn (a Hilton property) and had no issue getting online through their portal.

In the future, if there is a hotel I encounter where I can’t access the captive portal, are there any steps you’d like me to take to try and document the network to try and find a solution?

1 Like

Can you tell me the repeater just don’t connect or it is connected, but the portal just didn’t pop up?

It would connect and receive an IP address but the captive portal could never be accessed. If I remember correctly, Firefox would give the error “ERR_EMPTY_RESPONSE” and timeout the page.

Have you tried other browsers?

In one or my test on iPad and safari the portal didn’t pop up. But when using Andriod and chrome it just works.

I tried Chrome on a Windows based laptop and Firefox on an Android phone.

That firmware bricked mine :person_facepalming:

You also want to make sure that it’s not using a saved HTTPS URL as some portals don’t like HTTPS as the initial connection. Try typing something like HTTP://


It defaulted to http (so I gave https a try but that didn’t work either!).