Cannot connect to hotel Wifi with new Beryl AX - IOS devices work fine

I didn’t follow what you meant here.

This is from 4 years ago: GitHub - gl-inet/portal-detection
Has anyone been down that road?

1 Like

I meant that’s a very important captive portal detection url, and that list is very long to have forgotten to include it.

Who wants to have to compile a package. If it ever worked reliability, then it should be released.

Hello, I have a new Beryl AX and finally took it to my first trip. I set it up prior to the trip and it worked fine connecting to my home network acting as a wireless repeater. I was connected to my Ubiquiti network using the AC Lite and nanoHD AP’s. I am still currently able to connect to my iPhone’s hotspot from the Beryl AX

I am able to connected to the hotel wifi fine with my iPhone 13 mini, and windows 11 laptop but the Beryl AX keeps saying it cannot connect and will try again later. I’ve tried the following firmware, all fresh settings

  • 4.4.6 stable
  • 4.5.0 beta
  • 4.5.0 latest snapshot (Nov 7,2023)
    and all cannot connect to the hotel wifi. The hotel is small and not a chain, using what looks like a Linksys router.

I’ve attached the logs from the router on 4.4.6. Thanks in advance!

logread.zip (25.8 KB)

Please read all posts here: Hilton ethernet connection portal error - #3 by AdamK

1 Like

I checked the log. Is the log obtained immediatelly when the repeater failed?

I don’t have too much info about the repeater connection from t his log.

Does Beryl AX found the wifi network?
What is the wifi band and channel?
What is the exact message from the UI? Maybe give a screenshot.

I never understood the fuss with captive portals. I’ve never had an issue with my Beryl AX. I login once and every time I open my laptop back up from sleep I’m immediately back on the network. No re-authentication needed.

Yes that was immediately after the repeater failed. I have waited a couple more minutes before exporting the attached logs.

The Beryl AX does see the wifi network whenever I do a scan.
Mode AX, Channel 44 (5220MHz), Width 80 MHz.
Exact message is

“Connection failed will retry later…
Could not find network, please check the SSID and security type you entered.
While attempting to reconnect, your router will periodically scan for Wi-Fi networks, and your
guest Wi-Fi network will be temporarily unavailable during this scan.”

The above message is what shows up after waiting for a couple minutes with the generic Connection failed will retry later message.

I have screenshots of the above but since I’m a new user I’m only allowed to have one attachment.

logread.zip (24.7 KB)I

If I remember correctly I believe the issues stem from the type of authentication that the captive portal uses. When the captive portal uses this “special” authentication the MediaTek chipset routers have problems where the Qualcomm based routers do not (or maybe it’s the other way around).

Did you ket settings when you upgrade/downgrade firmware?

If yes can you reset the firmware and check again?

I did not keep settings when I flashed between 4.4.6, 4.5.0 beta, 4.5.0 snapshot.

All instances did not connect to the wifi

I did a bit more testing, mainly on 4.5.0 beta. I upgraded without keeping the settings. I also checked how my laptop was connecting to the WiFi and matched those settings with the Beryl AX via the Wireless Menu.

Laptop was connecting by WIFI 4 (802.11n), WPA2-Personal, 5GHz, Channel 44.

I disabled 2.4GHz on the Beryl AX, and forced it to n/ac (no ax) on the 5GHz at Channel 44 and still no luck.

I’ve attached the logs, I tried many times so maybe you can decipher it better than I can. One thing that stood out was there was an association timeout with code 16 and from what I can find online it means “Authentication rejected due to timeout waiting for next frame in sequence”

From what I can see, the SSID goes in and out (disappears and comes back) whenever I try to connect to it. In LuCi, I can see that it shows up, then disappears as well.

I’m checking out of this hotel tomorrow but would be a good use case for firmware upgrades. I found the Beryl AX also cannot connect (and see the SSID) to an industrial rugged modem/router (Brand: MicroHard) I have access to that gives out 2.4GHz but that’s another issue.

logread.zip (33.7 KB)

https://file.io/BMJUBNNEA4fn

Please try this temporary firmware.

It worked! I flashed without keeping settings and it connected the first try. I’ve attached the logread for your reference.

Just for more data. Speedtest directly to the hotel AP on my phone I was able to get 25.1Mbps down/4.8Mbps up. Through the MT3000 repeating the hotel AP 4.4Mbps down/4.2Mbps up.

The front LED is still blinking like it’s not connected to an AP/source.

Let me know if you have any other questions. Luckily I was able to test this before I checked out.

Thanks for your hard work!

logread.zip (33.0 KB)

The LED issue is because that this is a testing firmware, with various bugs.

The speed may not be able to solve easily because the situation can be complicated.

Hello,
I’m having a very similar issue on firmware 4.4.6 but instead of hotel wifi, I’m trying to work in repeater mode with VPN client enabled and I can’t connect to some home wifi routers while others work just fine. I’m attaching my log where I try to connect to one of the “faulty” networks. Can you look into it? I see a lot of these entries: wrong IE_HT_CAP.

Also, can you please re-upload the temporary firmware somewhere else as the link you have provided is expired? Thanks.

logread.zip (27.4 KB)

1 Like

https://file.io/Galt5Bgn8qCo

Please try this temporary firmware.

Thank you for your quick reply but when I click this link, I can only see

The transfer you requested has been deleted.

just like for the previous link. Can you please double check? Thanks.

1 Like

https://file.io/1OQJVYUZ3wDI