Cannot connect to open hotel wifi anymore, getting wrong key when connecting

My beryl was disconnected from hotel wifi this night. I tried to reconnect but was not successful.
I tried rebooting, change WAN mac, delete wifi config and reconnect again, but no success.

When trying to connect, I get a message “wrong key” when trying to connect after searching.
This hotel wifi has no encryption, the password is entered afterwards in a captive portal.

Why cannot I connect anymore, I did the same about 2 days ago and it worked fine

It seems a bug in firmware 3.211.

Can you change back to 3.203 and try?

I changed back to 203 without reset and it connected again. I then went back to 211 and it did not connect. I then installed 211 again with purging config and it connected again

Is there already a beta version where this is fixed?

Not yet have a beta firmware. Will push.

Thank you,

may I ask, what appears to be the bug?

“Wrong key” is definitely a bug because it is not.

Firmware 3.211 has this bug especially when connecting to iphone hotspot.

So, I tried again at the same hotel, the same problem again.
I was able to connect last week, not anymore today “wrong key” again

Can you try this:

In WiFi settings, change bandwidth to fixed e.g. HT20. Do not use HT20/HT40.

Do this for both 2.4G and 5G wifi.

you mean for the wifi that is created by the Beryl to connect laptop/smartphone to and not the wifi that connects to the hotel wifi?

I mean the wifi of Beryl itself. This setting will affect repeater as well.

I just did that and it appears to be working.

Is this the bug? That this setting for private wifi affects repeater wifi?

It is a bug. Fixing.


Do I understand correctly, if hotel WIFI does not allow something other than 20 MHz, setting this to Auto could cause trouble? If hotel WIFI would allow 40 MHz, this would not be a problem?

Anyway, the workaround appears to work, I had this problem not anymore. I am at a different hotel now.

You can try the new firmware update:

I do not work for and I am not directly associated with GL.iNet

1 Like

So, I am at the same hotel again. I get the Wrong key message again.

I am still on 3.211 stable with Wifi locked on 20 MHz, the hotel wifi has 20MHz as well, as my smartphone reports. This worked last time but now I get the same wrong key message again

I will therefore try 3.212 beta3 now, as the fix was already implemented in an earlier snapshot


reporting back after updating to beta3 3.212, with keeping the previous settings:

I get the wrong key message, should the fix be implemented already?

Hi, I now installed the latest snapshot, there it works.

@alzhao can it really be the fix is not present in the latest beta, only in the latest snapshot?

1 Like


I am now in a different room of the same hotel, having the snapshot where it worked as described above, but again I am getting the wrong key error…

So the same firmware, worked in one room. But after you change room it happens again?

It has this problem everytime?

I think the problem stays the same.

The thing is…
After changing the room I was able to connect to hotel Wifi, with no change to the firmware (so the old beta). Then I had to disconnect the beryl from power and reconnect it and then it did not connect anymore, problem as described above with “wrong key”. I then flashed the newest beta with keeping settings - “wrong key” again. I then flashed the same newest beta without keeping settings - “wrong key” again…