Cannot connect to open hotel wifi anymore, getting wrong key when connecting

you mean for the wifi that is created by the Beryl to connect laptop/smartphone to and not the wifi that connects to the hotel wifi?

I mean the wifi of Beryl itself. This setting will affect repeater as well.

I just did that and it appears to be working.

Is this the bug? That this setting for private wifi affects repeater wifi?

It is a bug. Fixing.


Do I understand correctly, if hotel WIFI does not allow something other than 20 MHz, setting this to Auto could cause trouble? If hotel WIFI would allow 40 MHz, this would not be a problem?

Anyway, the workaround appears to work, I had this problem not anymore. I am at a different hotel now.

You can try the new firmware update:

I do not work for and I am not directly associated with GL.iNet

1 Like

So, I am at the same hotel again. I get the Wrong key message again.

I am still on 3.211 stable with Wifi locked on 20 MHz, the hotel wifi has 20MHz as well, as my smartphone reports. This worked last time but now I get the same wrong key message again

I will therefore try 3.212 beta3 now, as the fix was already implemented in an earlier snapshot


reporting back after updating to beta3 3.212, with keeping the previous settings:

I get the wrong key message, should the fix be implemented already?

Hi, I now installed the latest snapshot, there it works.

@alzhao can it really be the fix is not present in the latest beta, only in the latest snapshot?

1 Like


I am now in a different room of the same hotel, having the snapshot where it worked as described above, but again I am getting the wrong key error…

So the same firmware, worked in one room. But after you change room it happens again?

It has this problem everytime?

I think the problem stays the same.

The thing is…
After changing the room I was able to connect to hotel Wifi, with no change to the firmware (so the old beta). Then I had to disconnect the beryl from power and reconnect it and then it did not connect anymore, problem as described above with “wrong key”. I then flashed the newest beta with keeping settings - “wrong key” again. I then flashed the same newest beta without keeping settings - “wrong key” again…


Sorry can you go back to 3.203 first.

Recent update of Beryl is broken in this part. Will fix on Thursday.


I tested the 0505 snapshot firmware, but it does not work, is it not fixed in this version?

A different question:
is there a firmware with the new driver and with the “wrong key” fix?
(MT1300 does not connect to hotel Wifi, why?)

I tried the 0506 snapshot, same wrong key :frowning:

I now tried a different open Wifi on another hotel location (but separate from the one before): I get the same "“wrong key” with this 0506 snapshot :frowning:

I suspect this would happen on all open Wifi then?

I now use my 750 Creta again, I bought the Beryl to replace the Creta, but at the current state I cannot do that :frowning: Not happy about that :frowning:

Sorry the snapshot didn’t apply the fix.

Will fix the problem asap!

1 Like

I just tried snapshot openwrt-mt300n-v2-3.212-0513.bin (Date: 2022-05-12 20:13:47) on my GL-MT300N-V2 Mango, still get “wrong key”.
I hope you will find a solution for this annoying bug.
Eric from Paris.

I tested the snapshot on May 12 and I don’t have wrong key message anymore.

Can you give further details? e.g. SSID and key.


I installed the 1805 snapshot on my Beryl and still get the wrong key message.

The Wifi Name is KP1_Guest and there is no key, it is an open Wifi.

I see. @JerryZhao can you have a check?